Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a headless file server running debian that just stopped connecting to the internet. Console output:

Dmesg:

[   84.248344] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   85.941389] svc: failed to register lockdv1 RPC service (errno 97).
[   85.942416] NFSD: Using /var/lib/nfs/v4recovery as the NFSv4 state recovery directory
[   85.978573] NFSD: starting 90-second grace period
[   87.433777] tg3: eth0: Link is up at 1000 Mbps, full duplex.
[   87.433780] tg3: eth0: Flow control is on for TX and on for RX.
[   87.433822] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   97.588019] eth0: no IPv6 routers present
[  980.549773] tg3: eth0: Link is down.
[ 1080.251698] tg3: eth0: Link is up at 1000 Mbps, full duplex.
[ 1080.251701] tg3: eth0: Flow control is on for TX and on for RX


netstat -r:
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
10.0.0.0        *               255.255.255.0   U         0 0          0 eth0
default         10.0.0.1        0.0.0.0         UG        0 0          0 eth0

Contests of /etc/network/interfaces file:


# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp

I can still get into the server itself from my local network. I've switched out the physical cables just to rule that out, and am willing to replace the network card if it comes to that, I have spares.

[Edit] Added the console output. I'll admit once I got this up and running last summer I pretty much left it at that. My partner and I moved recently and from the moment I turned it back on that's when the problems began. I'm just now noticing that I can't get online because I tried to run an old bot script I wrote and it kept timing out. Upon trying to update my packaging that too kept timing out so I figured something was up.

Ifconfig and getent cause bash to tell me they're not installed at all. Again, I really did just set this up and leave it the hell alone. I've been an arch user for years and just didn't want to have to spend nearly the amount of time with this that I do on my laptop.

share|improve this question
    
What is the output of: cat /etc/network/interfaces. Is network-manager installed, if so remove it, it's not needed on a server and can lead to problems. Are the ethernet ports on the computer and router set to auto negotiate or a fixed speed? Try to switch it from one to the other. –  aseq Apr 6 '12 at 21:39

1 Answer 1

"My server stopped connecting to the internet" can be caused by a variet of factors.

Here are some basic network diagnostics you should run through before you start swapping cables and cards. If these don't lead you to a solution you may want to update your question to show the output of these commands.

This help identify basic network configuration problems:

  • What does ifconfig show? Do you see the interface? Does the interface have the ip address you expect?

These help identify routing problems:

  • What does netstat -r show? In particular, is there a default route defined, and is it correct?

  • Are you able to ping the default gateway?

  • Are you able to ping or otherwise connect to other machines on the same network?

These help identify hostname translation problems:

  • Are you able to successfully resolve hostnames using the host command? That is, if you type host www.google.com, do you get an answer?

  • Are you able to successfully resolve hostnames using the getent command? That is, if you type getent hosts www.google.com do you get answer?

share|improve this answer
    
I've edited the information you and another user requested. Ping is fine locally, and I can resolve hostnames. But whenever I try and do antyhhing else ( like update my packages ) that requires the internet I keep getting timeouts. I also just noticed in my router interface ( I'm using Comasts' Xfinity router ) it is now listed as "unknown device". –  Wick Apr 7 '12 at 5:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.