Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have Windows 2008 Server R2, and I am trying to install FTP services. My problem is I can't connect from outside, FileZilla complains with:

Error:  Connection timed out
Error:  Could not connect to server

Here is what I did.

With the Server Manager, I've installed the Roles FTP Server, FTP Service and FTP Extensibility.

In Internet Information Services version 7.5, I've chosen Add FTP Site, enabled Basic Authentication, Allow a user to connect Read and Write. In FTP Firewall support on the main server, just after start page, I've set Data Channel Port Range to 49100-49250 and set the external IP Address as the one I see from outside.

If I click on FTP IPv4 Address and Domain Restrictions, and click on Edit Feature Settings, I see that access for unspecified clients is set to Allow, so I click OK without changing those defaults.

In FTP SSL Policy, I've set to Require SSL connection, certificate is self signed. I tried to connect with FileZilla from the same host and it works, however it doesn't work remotely, as I said above.

I've enabled pfirewall.log, but apparently nothing gets logged. The server is in Amazon EC2, and on the security group inbound firewall rules, I've set that ports 21 and ports 49100-49250 accepts connections from everywhere.

What else should I be checking to solve the problem?

share|improve this question
    
Are you just trying to get files onto the server because you are using Server Core? If you are, I have a much better soution. –  paradroid Apr 6 '12 at 22:52
    
no, i have to give accounts to many users –  stivlo Apr 7 '12 at 3:19
    
Oh okay. You could always use an SFTP server instead of using FTPS, and I'm sure you know that FTP is very unsecure. Windows users could use FileZilla or WinSCP to upload files. Dreamweaver also has SFTP support built-in. –  paradroid Apr 7 '12 at 3:40
    
FTP should not be insecure when used with Policy always SSL, the insecurity comes from plain passwords sent out on the clear, while SSL encrypts them. I will take a look to SFTP. –  stivlo Apr 7 '12 at 3:51
    
If you do a telnet to the tcp ports you set up from outside, does it work ? –  Mathieu Chateau Apr 7 '12 at 7:48
show 2 more comments

2 Answers

Is Windows Firewall turned on? I haven't looked at Windows servers on Amazon, but from memory its turned on by default and is fairly robust in what it's blocking.

Just check to see if it is switched on and check to see if FTP is allowed through that.

share|improve this answer
    
yes in the comments, I wrote: I changed the setting from require SSL connection to allow SSL connection and it works –  stivlo Apr 11 '12 at 9:20
add comment

In Filezilla, for the connection setting, go to the Transfer Settings tab and try Passive instead of Default or Active. Explanation here: http://slacksite.com/other/ftp.html

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.