Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I verified that my postfix installation / relaying setup worked. Now I am having trouble with procmail. I have it wired to postfix with the following command:

mailbox_command = /usr/bin/procmail -f -a "$USER"

I have nothing in my procmail config but the following:

LOGFILE=/var/procmailrc/log

And I send an email to a recipient that previously worked (before I attached procmail). Now it fails with error:

Apr  6 14:07:05 localhost postfix/qmgr[15194]: D0C3DFF6E1: from=<double-bounce@spamkill0.XXXXX>, size=938, nrcpt=1 (queue active)
Apr  6 14:07:05 localhost postfix/local[1953]: D0C3DFF6E1: to=<root@spamkill0.XXXXX>, orig_to=<postmaster>, relay=local, delay=0.05, delays=0.02/0.01/0/0.02, dsn=5.2.0, status=bounced (can't create user output file. Command output: procmail: Couldn't create "/var/spool/mail/nobody" procmail: Couldn't read "//root" )
Apr  6 14:07:05 localhost postfix/bounce[1955]: warning: D0C3DFF6E1: undeliverable postmaster notification discarded
Apr  6 14:07:05 localhost postfix/qmgr[15194]: D0C3DFF6E1: removed

It seems like there is some sort of permissions issue but I do not know what the problem is, nor do I understand how I would go about diagnosing it further. The logfile that I specified is empty, by the way.

How can I make procmail+postfix work?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

i just get into the same and find the answer

$ sudo chmod g+s /usr/bin/procmail

The answer was in
http://www.irbs.net/internet/postfix/0202/1677.html

share|improve this answer
1  
Please summarize the link, it might go away any time. –  vonbrand Jun 6 '13 at 1:41

Quite likely the user does not have permission to write to /var/procmailrc.

If you really insist on having central logging of all deliveries, you might want to rig some sort of arrangement to run Procmail under logger(8) or the local equivalent.

share|improve this answer

It looks like postfix is not passing the name to procmail, or is sending nobody (but I'd say the first is more likely). If your users are virtual, you need to set procmail up in a specific manner, if users are actual system user, procmail should be configured in a different manner.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.