Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

From a Windows Vista client using Cygwin, I am not be able to ssh to a Ubuntu server.

I have two other clients (one Vista and one Windows 7) which can SSH to the server. All three are using Cygwin.

Here are the logs from both sides for the same attempt

Client-> http://pastie.org/3740969

Server-> http://pastie.org/3740960

share|improve this question

2 Answers 2

up vote 2 down vote accepted

The problem with with a firewall installed on the computer (BlackIce)

Even thought Putty worked correctly SSH from Cygwin did not.

Uninstalled BlackIce, SSH worked. Reinstalled BlackIce and still working so must have been something with the BlackIce installation.

share|improve this answer
1  
I think in BlackIce, you have to whitelist by applications, not by network port. It doesn't quite work like iptables on Linux. –  cjc Apr 10 '12 at 17:20
    
Doh! Thanks for the update. =) –  Wesley Apr 10 '12 at 20:45

Look to perfmon counters for network related errors and resends. It may very well be that some portion of your TCP/IP stack is destroying packets on the client.

The impatient-person's replacement for a perfmon analysis is netstat -es on the client machine that is having problems. Compare the numbers from one of the clients that isn't having trouble.

If you want to perform a bit of flailing, reset the TCP/IP stack. Then uninstall and re-install the drivers for your NIC. Make sure you have the latest vendor-supplied bits.

If that fails, try a new network card. Somehow, I sense a subtle physical layer problem in this scenario.

share|improve this answer
    
I reset TCP/IP Stack and still have the problem. I also tried to do SSH using Putty and that worked. So this does seem to be related to Cygwin and not Hardware. –  noel_g Apr 9 '12 at 22:22
    
@noel_g what version of Cygwin are you using? –  Wesley Apr 9 '12 at 22:27
    
cygcheck -V shows 1.7.11 –  noel_g Apr 9 '12 at 22:36
    
@noel_g Latest version is 1.7.13-1 - not sure if that would help things. Grasping at straws now. –  Wesley Apr 9 '12 at 22:37
    
FYI, I noticed that on Putty I was asked to accept certificate from the server and I was asked the same thing on the other 2 machines where I can SSH from cygwin. This particular box is not asking me to accept the certificate. I looked in /.ssh and ~/.ssh on the client and I don't see where this could be stored. Expected to see it in known_hosts –  noel_g Apr 9 '12 at 22:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.