Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a partition that is formatted as ext3 I dd unmount it. Formatted as xfs (for quicker format) and I got an error. When I formatted it as ext3 again, it worked. What is the command to format an ext3 as xfs ? This is an Amazon EBS volume that I need to empty.

# umount /data

 # time mkfs.xfs -f /dev/sdf1
meta-data=/dev/sdf1              isize=256    agcount=32, agsize=8388565 blks
         =                       sectsz=512   attr=0
data     =                       bsize=4096   blocks=268434080, imaxpct=25
         =                       sunit=0      swidth=0 blks, unwritten=1
naming   =version 2              bsize=4096
log      =internal log           bsize=4096   blocks=32768, version=1
         =                       sectsz=512   sunit=0 blks, lazy-count=0
realtime =none                   extsz=4096   blocks=0, rtextents=0

real    0m11.238s
user    0m0.001s
sys     0m0.002s

# mount /data
mount: special device /dev/sdm does not exist
share|improve this question

1 Answer 1

up vote 4 down vote accepted

The mkfs.xfs worked fine; you got an error on mount because you're trying to mount the wrong thing. Try mount /dev/sdf1 /data and things will probably work out significantly better. Or you could edit your /etc/fstab to reflect the correct device-to-mountpoint mapping, and then use mount /data as you've been doing.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.