Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to set an attribute to another user while I was logged with my account, which is member of Domain Admins group of the Active Directory.

Error while executing LDIF- [LDAP: error code 50 - 00002098: SecErr: DSID-03150A45, problem 4003 (INSUFF_ACCESS_RIGHTS), data java.lang.Exception: [LDAP: error code 50 - 00002098: SecErr: DSID-03150A45, problem 4003 (INSUFF_ACCESS_RIGHTS), data 0

What I need to do in order to be able to edit data using LDAP?

share|improve this question
up vote 1 down vote accepted

Right-click on the application and select Run as Administrator.

When you are a member of one of the special restricted groups such as Domain Admins, Enterprise Admins, or Administrators, those group memberships are blocked from your normal process token. To use these group memberships, you need to elevate by using Run as Administrator.

You can verify that the groups are blocked by running SysInternals' Process Explorer, right-click on the application, select Properties, and on the Security tab, the groups will have a Deny in the Flags column.

share|improve this answer
Your answer is not valid in my case, I'm running from Linux and conecting to LDAP so local process permission has nothing to do with that. Still, I solved the problem, I was connecting using a normal user instead of the admin one :p – sorin Apr 7 '12 at 13:19

If you are Domain Admin you should be able to do this. In my case I was connecting using another user.

share|improve this answer
You may want to update your question - you were not, in fact, acting as Domain admin. – uSlackr Apr 8 '12 at 15:10

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.