Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to set up the Mercurial 64-bit client on an Atlassian Bamboo build server. The automated builds were giving errors trying to check code out of Mercurial, so I tried to test it from the command line, and I get the same error.

> hg init
abort: Provider DLL failed to initialize correctly

The OS is a Windows Server 2008 clean install with SP2 applied.

I honestly have no idea what's causing this. Has anyone seen this before?


share|improve this question

I had this problem before and even if I cannot test it anymore, I think it's an incompatibility between 32 and 64bits. Maybe you should try to install a 32bit version of Mercurial ?


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.