Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have absolutely no idea what I am doing wrong here. I have followed just about every guide there is with installing cakephp on shared hosting and I am still having problems. I have also started over each time when following a guide. Maybe someone can help me out here as I am out of options.

Here is my current setup:

/
  app
      webroot
  vendors
  lib
      cake
  public_html
      .htaccess
      index.php
  plugins

I have configured the index.php file in the public_html to point to the correct files. I have also done this in the index.php file located in webroot folder. I am getting an Internal 500 server error and it says to check my logs for what the error specifically is. However there are no logs being generated. I removed the .htaccess file from the public_html folder and I get the following errors:

Warning: require(/app/webroot/index.php) [function.require]: failed to open stream: No such file or directory in /home/user/public_html/index.php on line 40

Fatal error: require() [function.require]: Failed opening required '/app/webroot/index.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/user/public_html/index.php on line 40

line 40 is

require APP_DIR . DS . WEBROOT_DIR . DS . 'index.php';

DS = "/"

WEBROOT_DIR = "app"

Anyone have any suggestions? I am at lost at what I am doing wrong.

share|improve this question

1 Answer 1

you need the rewrite.mod enabled for php to work: http://wiki.ubuntuusers.de/Apache/modrewrite

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.