Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have followed this exact tutorial on installing php on a Fedora 15 system.

I have all the necessary packages installed with no errors. Yet the simple phpinfo() test page will show - it will show a blank page. When I try to see the source, I see it downloaded my .php file as plain text and loaded it in the browser.

So I am guessing for some reason php module is not loaded in httpd. Does anyone have any idea why?

P.S. I am really hoping SELinux this time has nothing to do with this!

share|improve this question
Sift through your Apache error logs to see if it's reporting anything. /var/log/httpd/error_log – Wesley Apr 7 '12 at 21:50
Also, as silly as it sounds, paste your index.php file in your post. – Wesley Apr 7 '12 at 21:52
Check /var/log/audit/audit.log if you expect SELinux. – Charles Apr 7 '12 at 21:52
Index.php: <? phpinfo(); ?> SELinux - permissive mode (setenforce 0). Some key items in the error log after server restart: (1) SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0 (2) [Sun Apr 08 09:19:55 2012] [notice] Apache/2.2.22 (Unix) DAV/2 PHP/5.3.10 configured -- resuming normal operations. – George Apr 8 '12 at 6:21

It could be an issue with SELinux. To narrow it down, check to see if it's even turned on:

selinuxenabled && echo enabled || echo disabled

If it's turned on, temporarily disable it with:

echo 0 > /selinux/enforce

SELinux will be enabled after a reboot, or until you manually enable it:

echo 1 > /selinux/enforce

share|improve this answer
Thank you, I tried that - it did not make a change. I believe there is a configuration problem in httpd.conf or somewhere, a search for 'php' in httpd.conf returns nothing despite having all the packages needed. – George Apr 8 '12 at 6:26

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.