Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have postfix and dovecot installed on CentOS 6 (linode) along with MySQL. The table and user is already set up, postfix installed fine, but dovecot gives me this error in the mail log:

Warning: Killed with signal 15 (by pid=9415 uid=0 code=kill)

The next few lines say this:

Apr  7 16:13:35 dovecot: master: Dovecot v2.0.9 starting up (core dumps disabled)
Apr  7 16:13:35 dovecot: config: Warning: NOTE: You can get a new clean config file with: doveconf -n > dovecot-new.conf
Apr  7 16:13:35 dovecot: config: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:1: protocols=pop3s is no longer supported. to disable non-ssl pop3, use service pop3-login { inet_listener pop3 { p$
Apr  7 16:13:35 dovecot: config: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:5: ssl_cert_file has been replaced by ssl_cert = <file
Apr  7 16:13:35 dovecot: config: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:6: ssl_key_file has been replaced by ssl_key = <file
Apr  7 16:13:35 dovecot: config: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:8: namespace private {} has been replaced by namespace { type=private }
Apr  7 16:13:35 dovecot: config: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:24: add auth_ prefix to all settings inside auth {} and remove the auth {} section completely
Apr  7 16:13:35 dovecot: config: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:25: auth_user has been replaced by service auth { user }

I am following directions for the install on CentOS 5 with changes in the dovecot.conf file from different sources specific to CentOS 6. So the dovecot.conf file might not be correct, but there is no good source I have found yet for making dovecot install correctly.

Can anyone tell me what the error above means? The terminal does not give any message as to start OK or FAIL. When I issue the service dovecot start command, it says: Starting Dovecot Imap: and nothing more.

share|improve this question
    
Have you... read what it's telling you? –  Ignacio Vazquez-Abrams Apr 8 '12 at 1:32
1  
@IgnacioVazquez-Abrams: Don't be silly... that's what Serverfault is for! –  womble Apr 8 '12 at 1:54
add comment

2 Answers

up vote 1 down vote accepted

Check your dovecot.conf file to make sure that all curly braces are terminated.

In fact, since this is a new setup, just run doveconf -n > dovecot-new.conf and then take the new configuration file and replace the current one with it.

share|improve this answer
    
Thanks a lot. I tried to add some stuff to the conf file and it looks like I left a brace out. Then I uninstalled/reinstalled, left the conf as default and the thing starts. It does give this message again (Warning: Killed with signal 15 (by pid=9749 uid=0 code=kill) but testing with a telnet command shows it's working now. Really appreciate your helpful reply. Thanks again. –  jamie Apr 8 '12 at 3:40
add comment

Whatever PID 9415 is, it decided that it wanted to send a SIGTERM to your dovecot server. I'd start by finding out what that is (ps ftw) and attempting to determine why it's taken such a terminal dislike to Dovecot.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.