Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Ubuntu 11.04 running with two wireless interfaces -- one onboard (seen as wlan0) and one external card via USB, seen as wlan1.

I would like to only use the USB card, completely ignoring the onboard one. Currently when I enable wireless both interfaces come up. How do I make Ubuntu ignore wlan0?

share|improve this question
add comment

2 Answers

You should check in /etc/network/interfaces.

Make sure that there is no entry in that file that allows that interface to start up. It's entirely likely that the interface is set to 'hotplug'.

In fact, if you're at all comfortable with the command-line, there's quite a bit of information available in the man page for the interfaces at: man interfaces

share|improve this answer
    
/etc/network/interfaces only contains "auto eth0", no mention of wlan0 or wlan1 –  vmalloc Apr 8 '12 at 19:38
    
Thanks for the heads up. They must've changed that since 10.04LTS. –  Magellan Apr 8 '12 at 20:49
add comment

Place the following into /etc/rc.local:

#!/bin/bash
sudo ifdown wlan0 

It's also worth noting that it may be possible to disable your internal wireless adapter in your BIOS.

share|improve this answer
    
This appears to work only temporarily - the interface automatically comes back up after a few minutes... –  vmalloc Apr 8 '12 at 9:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.