Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I keep getting dependency issues when I try to run yum install php-devel

yum install --skip-broken php-devel

....
--> Finished Dependency Resolution
php-5.1.6-32.el5.i386 from base has depsolving problems
  --> Missing Dependency: php-common = 5.1.6-32.el5 is needed by package php-5.1.6-32.el5.i386 (base)
php-cli-5.1.6-32.el5.i386 from base has depsolving problems
  --> Missing Dependency: php-common = 5.1.6-32.el5 is needed by package php-cli-5.1.6-32.el5.i386 (base)
--> Running transaction check
---> Package php.i386 0:5.1.6-32.el5 set to be updated
--> Processing Dependency: php = 5.1.6-32.el5 for package: php-devel
---> Package php-cli.i386 0:5.1.6-32.el5 set to be updated
--> Finished Dependency Resolution
php-devel-5.1.6-32.el5.i386 from base has depsolving problems
  --> Missing Dependency: php = 5.1.6-32.el5 is needed by package php-devel-5.1.6-32.el5.i386 (base)

Packages skipped because of dependency problems:
    autoconf-2.59-12.noarch from base
    automake-1.9.6-2.3.el5.noarch from base
    imake-1.0.2-3.i386 from base
    php-5.1.6-32.el5.i386 from base
    php-cli-5.1.6-32.el5.i386 from base
    php-devel-5.1.6-32.el5.i386 from base

Any ideas?

share|improve this question

2 Answers 2

as per error message - you are missing php-common package to satisfy yum installer. You might want to try to clean your cache (yum clean all) and re-run yum install php-devel command.

Perhaps repo which provides php-common is disabled? (yum repolist all)?

Update

Also make sure that you are installing for the right arch... uname -r. To force package installation for specific arch you can: yum install php-devel.x86_64

share|improve this answer
    
I did what you advised, but still the same dep errors. screensnapr.com/v/Q6528a.jpg –  user962449 Apr 9 '12 at 0:06

why don't you want to install the dependancies? yum shows you what dependancies you need for the installation. otherwise you might as well just use a .rpm if you just want this one package.

share|improve this answer
    
are the dependencies I need the ones at the bottom? –  user962449 Apr 8 '12 at 23:18
    
no they are the packages skipped. the one you seem to need is php-common. try yum install php-devel and then it will suggest an an option of what it needs to do to install. (leave out the skip-broken –  user112570 Apr 8 '12 at 23:21
    
I already have php-common. screensnapr.com/v/ArwVW2.jpg –  user962449 Apr 8 '12 at 23:26
    
that list at the bottom is everything that has not been able to be installed and is needed for php-devel. if you do yum install php-devel then it should install everything you need for it to work. –  user112570 Apr 8 '12 at 23:28
    
It tells me that I need php-common, but I already have that installed. –  user962449 Apr 8 '12 at 23:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.