Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server with Internet connection and /etc/resolv.conf with Real DNS servers. when I put the server in a close network without internet the server become very slow. I suspect that it's the DNS resolving. any idea how to fix it? maybe with nsswitch.conf?

should I add [NOTFOUND=return] in hosts: files dns

thanks!! E.

share|improve this question
    
Elad, you should probably go back and work on your accept rate. You have a lot of questions with answers, none of which you have accepted, and this shows up to us as a "38% accept rate" warning. People may be more keen to help you if you can improve that a bit. –  MadHatter Apr 9 '12 at 7:56
    
sure. sorry!! can you please let me know which is the best way to do it? –  edotan Apr 9 '12 at 8:02
1  
Go to your user page (click your username at the top of just about any page), select Questions, visit each question which has a light (rather than bold) box around the "answers" count, pick the best answer, and click the "tick" outline next to the best answer. I'm sure there will be some where none of the answers is any good, but you should be able to accept one for a lot of your outstanding questions. Thanks! –  MadHatter Apr 9 '12 at 8:08
    
Will do. Thanks!! –  edotan Apr 9 '12 at 9:37
add comment

1 Answer 1

up vote 3 down vote accepted

It is better to ask a more deterministic question. What do you mean by very slow? The server overall performance is bad or some specific services are not responding as expected??

Yes, the DNS issues can result in some performance problems.

How to fix the issue:

  1. Configure your server to use a proper DNS server. At least, you can configure an internal one if you don't want/need to access public DNS servers.
  2. Disable DNS lookup for the relevant service and re-check. This depends on the service you are experiencing slow behavior. For example, you can add UseDNS no in sshd_config file for SSH service and so on.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.