Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a Drupal installation (php+mysql) in a server, and I'm trying to copy this installation to another server with the same configuration, same physical and virtual path, same db configuration, etc.

The thing is, in my new server I get the homepage to work, but not the inner pages, so I guess has something to do with rewrite (mod_rewrite is installed) (both .htaccess are the same).

When I access http://localhost/myweb/content/mypage I get a 404 or a "Forbidden" if I uncomment this in httpd.conf (original httpd.conf does not have this entry):

<Directory path/to/docs">
    DirectoryIndex index.php index.html
    Options Indexes FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

Any clue?

Thank you

share|improve this question

1 Answer 1

up vote 3 down vote accepted

If you have AllowOverride set to None ... .htaccess file is completely ignored by apache. It should be set to AllowOverride All.

Ref: AllowOverride

I assumed that your problem is within mod rewrite directives not properly read from .htaccess file - it might be elsewhere though ... give it a go.

share|improve this answer
    
That was it, thank you –  user761076 Apr 9 '12 at 18:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.