Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I login to the server using a domain account with administrator privileges and create a task in the Task Scheduler, I am unable to successfully save the Task once I select the following options: "Run whether the user is logged on or not" and "run with the highest priveleges" I am prompted to enter "Enter user account information for running this task." When I do, I get the following message:

Task Scheduler cannot apply your changes.
The user account is unknown, the password is incorrect, 
or the account does not have permission to modify the task.

When I check Log on as Batch Job Properties (found this from the Help documentation):

This policy is accessible by opening the Control Panel, 
Administrative Tools, and then Local Security Policy. 
In the Local Security Policy window, click Local Policy, 
User Rights Assignment, and then Logon as batch job. 

Everything is grayed out, so I can't add a user. How can I add a user or get the task to save?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Sounds like the setting is under the control of a Group Policy. You'll need to add the account in an existing GPO that applies to the server, or if that's too general then you could create a new GPO that just applies to that server via security filtering.

share|improve this answer
    
I'm going through my GPOs and I cannot figure out which one could possibly be affecting the Task Scheduler. Any other suggestions? –  Aaron Apr 10 '12 at 17:50
    
Use RSOP.msc to tell you which policy is affecting those settings –  Chris McKeown Apr 10 '12 at 19:34
    
Could I gain some insight on where exactly I should be looking within ROPS.msc? Thank you. –  Aaron Apr 11 '12 at 19:16
    
When you run RSOP.msc on the server that is affected, you'll get an interface that looks very much like the Group Policy editor. Drill down to Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> User Rights Assignment. In here you'll see a column at the top called 'source GPO'. Look there to see which Group Policy is setting the parts that you want to change. –  Chris McKeown Apr 11 '12 at 20:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.