Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I want to allow my VMWare machine to force the virtual network it's on into promiscuous mode so I can play around with honeyd. I received an error message that told me to go to http://vmware.com/info?id=161 to allow this behavior. Based on their advice, I did:

$ groupadd promiscuous
$ cat /etc/group | grep promiscuous
promiscuous:x:1002:robert
$ usermod -a -G promiscuous robert
$ id robert
uid=1000(robert) gid=1000(robert) groups=1000(robert),....,1002(promiscuous)
$ chgrp promiscuous /dev/vmnet8
$ chmod g+rw /dev/vmnet8
$ ls -l /dev/vmnet8
crw-rw---- 1 root promiscuous 119, 8 2012-03-29 10:29 /dev/vmnet8

Looks like I gave RW permission to the promiscuous group, and added myself. Except that VMWare still gives me an error message that says I cannot enter promiscuous mode. To try out the group thing, I tried:

$ echo "1" >/dev/vmnet8
bash: /dev/vmnet8: Permission denied

That really surprised me: It makes me think that I still haven't properly given myself the correct permissions... What am I missing?

share|improve this question

2 Answers 2

Have you enabled promiscuous mode on the VMWare host port group that this guest is running in?

share|improve this answer
    
These instructions don't seem to match at all with the graphical interface VMWare is giving me, so I'm not quite sure how to do this.. –  Robert Martin Apr 11 '12 at 16:53

Unless I'm missing something, this line: $ chgrp newgroup /dev/vmnet8 should read: $ chgrp promiscuous /dev/vmnet8

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.