Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Whenever, I try and run yum update I get the following error:

[root@server ~]# yum update
Loaded plugins: dellsysid, fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror01.idc.hinet.net
 * extras: mirror01.idc.hinet.net
 * rpmforge: fr2.rpmfind.net
 * updates: mirror01.idc.hinet.net
Excluding Packages in global exclude list
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package NetworkManager.x86_64 1:0.7.0-13.el5 set to be updated
---> Package NetworkManager-glib.x86_64 1:0.7.0-13.el5 set to be updated
---> Package SysVinit.x86_64 0:2.86-17.el5 set to be updated
---> Package acl.x86_64 0:2.2.39-8.el5 set to be updated
---> Package acpid.x86_64 0:1.0.4-12.el5 set to be updated
---> Package apr.x86_64 0:1.2.7-11.el5_6.5 set to be updated
---> Package aspell.x86_64 12:0.60.3-12 set to be updated
---> Package audit.x86_64 0:1.8-2.el5 set to be updated
---> Package audit-libs.x86_64 0:1.8-2.el5 set to be updated
---> Package audit-libs-python.x86_64 0:1.8-2.el5 set to be updated
---> Package authconfig.x86_64 0:5.3.21-7.el5 set to be updated
---> Package autofs.x86_64 1:5.0.1-0.rc2.163.el5 set to be updated
---> Package bash.x86_64 0:3.2-32.el5 set to be updated
---> Package bind.x86_64 30:9.3.6-20.P1.el5 set to be updated
---> Package bind-libs.x86_64 30:9.3.6-20.P1.el5 set to be updated
---> Package bind-utils.x86_64 30:9.3.6-20.P1.el5 set to be updated
---> Package binutils.x86_64 0:2.17.50.0.6-20.el5 set to be updated
---> Package centos-release.x86_64 10:5-8.el5.centos set to be updated
---> Package centos-release-notes.x86_64 0:5.8-0 set to be updated
---> Package coreutils.x86_64 0:5.97-34.el5_8.1 set to be updated
---> Package cpp.x86_64 0:4.1.2-52.el5 set to be updated
---> Package cpuspeed.x86_64 1:1.2.1-10.el5 set to be updated
---> Package crash.x86_64 0:5.1.8-1.el5.centos set to be updated
---> Package cryptsetup-luks.x86_64 0:1.0.3-8.el5 set to be updated
---> Package cups.x86_64 1:1.3.7-30.el5 set to be updated
---> Package cups-libs.x86_64 1:1.3.7-30.el5 set to be updated
---> Package curl.x86_64 0:7.15.5-15.el5 set to be updated
--> Processing Dependency: dbus = 1.1.2-15.el5_6 for package: dbus-libs
---> Package dbus.x86_64 0:1.1.2-16.el5_7 set to be updated
---> Package dbus-libs.x86_64 0:1.1.2-16.el5_7 set to be updated
---> Package device-mapper.x86_64 0:1.02.67-2.el5 set to be updated
---> Package device-mapper-event.x86_64 0:1.02.67-2.el5 set to be updated
---> Package device-mapper-multipath.x86_64 0:0.4.7-48.el5_8.1 set to be updated
---> Package dhclient.x86_64 12:3.0.5-31.el5 set to be updated
---> Package dmidecode.x86_64 1:2.11-1.el5 set to be updated
---> Package dmraid.x86_64 0:1.0.0.rc13-65.el5 set to be updated
---> Package dmraid-events.x86_64 0:1.0.0.rc13-65.el5 set to be updated
---> Package dump.x86_64 0:0.4b41-6.el5 set to be updated
---> Package e2fsprogs.x86_64 0:1.39-33.el5 set to be updated
---> Package e2fsprogs-devel.x86_64 0:1.39-33.el5 set to be updated
---> Package e2fsprogs-libs.x86_64 0:1.39-33.el5 set to be updated
---> Package ecryptfs-utils.x86_64 0:75-8.el5 set to be updated
---> Package file.x86_64 0:4.17-21 set to be updated
---> Package finger.x86_64 0:0.17-33 set to be updated
---> Package firstboot-tui.x86_64 0:1.4.27.9-1.el5.centos set to be updated
---> Package freetype.x86_64 0:2.2.1-28.el5_7.2 set to be updated
---> Package freetype-devel.x86_64 0:2.2.1-28.el5_7.2 set to be updated
---> Package ftp.x86_64 0:0.17-37.el5 set to be updated
---> Package gamin.x86_64 0:0.1.7-10.el5 set to be updated
---> Package gamin-python.x86_64 0:0.1.7-10.el5 set to be updated
---> Package gawk.x86_64 0:3.1.5-15.el5 set to be updated
---> Package gcc.x86_64 0:4.1.2-52.el5 set to be updated
---> Package gcc-c++.x86_64 0:4.1.2-52.el5 set to be updated
---> Package glibc.i686 0:2.5-81.el5_8.1 set to be updated
---> Package glibc.x86_64 0:2.5-81.el5_8.1 set to be updated
---> Package glibc-common.x86_64 0:2.5-81.el5_8.1 set to be updated
---> Package glibc-devel.x86_64 0:2.5-81.el5_8.1 set to be updated
---> Package glibc-headers.x86_64 0:2.5-81.el5_8.1 set to be updated
---> Package gnutls.x86_64 0:1.4.1-7.el5_8.2 set to be updated
---> Package groff.x86_64 0:1.18.1.1-13.el5 set to be updated
---> Package gtk2.x86_64 0:2.10.4-21.el5_7.7 set to be updated
---> Package gzip.x86_64 0:1.3.5-13.el5.centos set to be updated
---> Package hmaccalc.x86_64 0:0.9.6-4.el5 set to be updated
---> Package htop.x86_64 0:1.0.1-2.el5.rf set to be updated
---> Package hwdata.noarch 0:0.213.26-1.el5 set to be updated
---> Package ifd-egate.x86_64 0:0.05-17.el5 set to be updated
---> Package initscripts.x86_64 0:8.45.42-1.el5.centos set to be updated
---> Package iproute.x86_64 0:2.6.18-13.el5 set to be updated
---> Package iptables.x86_64 0:1.3.5-9.1.el5 set to be updated
---> Package iptables-ipv6.x86_64 0:1.3.5-9.1.el5 set to be updated
---> Package iscsi-initiator-utils.x86_64 0:6.2.0.872-13.el5 set to be updated
---> Package kernel.x86_64 0:2.6.18-308.1.1.el5 set to be installed
---> Package kernel-headers.x86_64 0:2.6.18-308.1.1.el5 set to be updated
---> Package kpartx.x86_64 0:0.4.7-48.el5_8.1 set to be updated
---> Package krb5-devel.x86_64 0:1.6.1-70.el5 set to be updated
---> Package krb5-libs.x86_64 0:1.6.1-70.el5 set to be updated
---> Package krb5-workstation.x86_64 0:1.6.1-70.el5 set to be updated
---> Package ksh.x86_64 0:20100621-5.el5_8.1 set to be updated
---> Package kudzu.x86_64 0:1.2.57.1.26-3.el5.centos set to be updated
---> Package less.x86_64 0:436-9.el5 set to be updated
---> Package lftp.x86_64 0:3.7.11-7.el5 set to be updated
---> Package libX11.x86_64 0:1.0.3-11.el5_7.1 set to be updated
---> Package libX11-devel.x86_64 0:1.0.3-11.el5_7.1 set to be updated
---> Package libXcursor.x86_64 0:1.1.7-1.2 set to be updated
---> Package libacl.x86_64 0:2.2.39-8.el5 set to be updated
---> Package libgcc.x86_64 0:4.1.2-52.el5 set to be updated
---> Package libgomp.x86_64 0:4.4.6-3.el5.1 set to be updated
---> Package libpng.x86_64 2:1.2.10-16.el5_8 set to be updated
---> Package libpng-devel.x86_64 2:1.2.10-16.el5_8 set to be updated
---> Package libsmbios.x86_64 0:2.2.27-3.2.el5 set to be updated
---> Package libstdc++.x86_64 0:4.1.2-52.el5 set to be updated
---> Package libstdc++-devel.x86_64 0:4.1.2-52.el5 set to be updated
---> Package libsysfs.x86_64 0:2.1.0-1.el5 set to be updated
---> Package libusb.x86_64 0:0.1.12-6.el5 set to be updated
---> Package libvolume_id.x86_64 0:095-14.27.el5_7.1 set to be updated
---> Package libxml2.x86_64 0:2.6.26-2.1.15.el5_8.2 set to be updated
---> Package libxml2-python.x86_64 0:2.6.26-2.1.15.el5_8.2 set to be updated
---> Package logrotate.x86_64 0:3.7.4-12 set to be updated
---> Package lsof.x86_64 0:4.78-6 set to be updated
---> Package lvm2.x86_64 0:2.02.88-7.el5 set to be updated
---> Package m2crypto.x86_64 0:0.16-8.el5 set to be updated
---> Package man.x86_64 0:1.6d-2.el5 set to be updated
---> Package man-pages.noarch 0:2.39-20.el5 set to be updated
---> Package mcelog.x86_64 1:0.9pre-1.32.el5 set to be updated
---> Package mesa-libGL.x86_64 0:6.5.1-7.10.el5 set to be updated
---> Package mesa-libGL-devel.x86_64 0:6.5.1-7.10.el5 set to be updated
---> Package microcode_ctl.x86_64 2:1.17-1.56.el5 set to be updated
---> Package mkinitrd.x86_64 0:5.1.19.6-75.el5 set to be updated
---> Package mktemp.x86_64 3:1.5-24.el5 set to be updated
--> Processing Dependency: nash = 5.1.19.6-68.el5_6.1 for package: mkinitrd
---> Package nash.x86_64 0:5.1.19.6-75.el5 set to be updated
---> Package net-snmp.x86_64 1:5.3.2.2-17.el5 set to be updated
---> Package net-snmp-devel.x86_64 1:5.3.2.2-17.el5 set to be updated
---> Package net-snmp-libs.x86_64 1:5.3.2.2-17.el5 set to be updated
---> Package net-snmp-utils.x86_64 1:5.3.2.2-17.el5 set to be updated
---> Package net-tools.x86_64 0:1.60-82.el5 set to be updated
---> Package nfs-utils.x86_64 1:1.0.9-60.el5 set to be updated
---> Package nfs-utils-lib.x86_64 0:1.0.8-7.9.el5 set to be updated
---> Package nscd.x86_64 0:2.5-81.el5_8.1 set to be updated
---> Package nspr.x86_64 0:4.8.9-1.el5_8 set to be updated
---> Package nspr-devel.x86_64 0:4.8.9-1.el5_8 set to be updated
---> Package nss.x86_64 0:3.13.1-5.el5_8 set to be updated
---> Package nss-devel.x86_64 0:3.13.1-5.el5_8 set to be updated
---> Package nss-tools.x86_64 0:3.13.1-5.el5_8 set to be updated
---> Package nss_ldap.x86_64 0:253-49.el5 set to be updated
---> Package ntp.x86_64 0:4.2.2p1-15.el5.centos.1 set to be updated
---> Package numactl.x86_64 0:0.9.8-12.el5_6 set to be updated
---> Package oddjob.x86_64 0:0.27-12.el5 set to be updated
---> Package oddjob-libs.x86_64 0:0.27-12.el5 set to be updated
---> Package openldap.x86_64 0:2.3.43-25.el5 set to be updated
---> Package openssh.x86_64 0:4.3p2-82.el5 set to be updated
---> Package openssh-clients.x86_64 0:4.3p2-82.el5 set to be updated
---> Package openssh-server.x86_64 0:4.3p2-82.el5 set to be updated
---> Package openssl.i686 0:0.9.8e-22.el5_8.1 set to be updated
---> Package openssl.x86_64 0:0.9.8e-22.el5_8.1 set to be updated
---> Package openssl-devel.x86_64 0:0.9.8e-22.el5_8.1 set to be updated
---> Package pam_krb5.x86_64 0:2.2.14-22.el5 set to be updated
---> Package pam_pkcs11.x86_64 0:0.5.3-26.el5 set to be updated
---> Package pango.x86_64 0:1.14.9-8.el5.centos.3 set to be updated
---> Package parted.x86_64 0:1.8.1-29.el5 set to be updated
---> Package pciutils.x86_64 0:3.1.7-5.el5 set to be updated
---> Package perl.x86_64 4:5.8.8-38.el5 set to be updated
---> Package perl-Compress-Raw-Bzip2.x86_64 0:2.037-1.el5.rf set to be updated
---> Package perl-Compress-Raw-Zlib.x86_64 0:2.037-1.el5.rf set to be updated
---> Package perl-rrdtool.x86_64 0:1.4.7-1.el5.rf set to be updated
---> Package poppler.x86_64 0:0.5.4-19.el5 set to be updated
---> Package poppler-utils.x86_64 0:0.5.4-19.el5 set to be updated
---> Package popt.x86_64 0:1.10.2.3-28.el5_8 set to be updated
---> Package postgresql-libs.x86_64 0:8.1.23-1.el5_7.3 set to be updated
---> Package procps.x86_64 0:3.2.7-18.el5 set to be updated
---> Package proftpd.x86_64 0:1.3.4a-1.el5.rf set to be updated
--> Processing Dependency: perl(Mail::Sendmail) for package: proftpd
---> Package python.x86_64 0:2.4.3-46.el5 set to be updated
---> Package python-ctypes.x86_64 0:1.0.2-3.el5 set to be updated
---> Package python-libs.x86_64 0:2.4.3-46.el5 set to be updated
---> Package python-smbios.x86_64 0:2.2.27-3.2.el5 set to be updated
---> Package rhpl.x86_64 0:0.194.1-2 set to be updated
---> Package rmt.x86_64 0:0.4b41-6.el5 set to be updated
---> Package rng-utils.x86_64 1:2.0-5.el5 set to be updated
---> Package rpm.x86_64 0:4.4.2.3-28.el5_8 set to be updated
---> Package rpm-build.x86_64 0:4.4.2.3-28.el5_8 set to be updated
---> Package rpm-devel.x86_64 0:4.4.2.3-28.el5_8 set to be updated
---> Package rpm-libs.x86_64 0:4.4.2.3-28.el5_8 set to be updated
---> Package rpm-python.x86_64 0:4.4.2.3-28.el5_8 set to be updated
---> Package rrdtool.x86_64 0:1.4.7-1.el5.rf set to be updated
---> Package rsh.x86_64 0:0.17-40.el5_7.1 set to be updated
---> Package rsync.x86_64 0:3.0.6-4.el5_7.1 set to be updated
---> Package ruby.x86_64 0:1.8.5-24.el5 set to be updated
---> Package ruby-libs.x86_64 0:1.8.5-24.el5 set to be updated
---> Package sblim-sfcb.x86_64 0:1.3.11-49.el5 set to be updated
---> Package sblim-sfcc.x86_64 0:2.2.2-49.el5 set to be updated
---> Package selinux-policy.noarch 0:2.4.6-327.el5 set to be updated
---> Package selinux-policy-targeted.noarch 0:2.4.6-327.el5 set to be updated
---> Package setup.noarch 0:2.5.58-9.el5 set to be updated
---> Package shadow-utils.x86_64 2:4.0.17-20.el5 set to be updated
---> Package smartmontools.x86_64 1:5.38-3.el5 set to be updated
---> Package smbios-utils-bin.x86_64 0:2.2.27-3.2.el5 set to be updated
---> Package smbios-utils-python.x86_64 0:2.2.27-3.2.el5 set to be updated
---> Package sos.noarch 0:1.7-9.62.el5 set to be updated
---> Package srvadmin-omilcore.x86_64 0:6.5.0-1.452.1.el5 set to be updated
---> Package strace.x86_64 0:4.5.18-11.el5_8 set to be updated
---> Package subversion.x86_64 0:1.6.11-7.el5_6.4 set to be updated
---> Package sudo.x86_64 0:1.7.2p1-13.el5 set to be updated
---> Package sysfsutils.x86_64 0:2.1.0-1.el5 set to be updated
---> Package syslinux.x86_64 0:3.11-7 set to be updated
---> Package system-config-network-tui.noarch 0:1.3.99.21-1.el5 set to be updated
---> Package talk.x86_64 0:0.17-31.el5 set to be updated
---> Package tar.x86_64 2:1.15.1-31.el5 set to be updated
---> Package traceroute.x86_64 3:2.0.1-6.el5 set to be updated
---> Package tzdata.x86_64 0:2012b-3.el5 set to be updated
---> Package udev.x86_64 0:095-14.27.el5_7.1 set to be updated
---> Package util-linux.x86_64 0:2.13-0.59.el5 set to be updated
---> Package vixie-cron.x86_64 4:4.1-81.el5 set to be updated
---> Package wget.x86_64 0:1.11.4-3.el5_8.1 set to be updated
---> Package xinetd.x86_64 2:2.3.14-16.el5 set to be updated
---> Package yp-tools.x86_64 0:2.9-2.el5 set to be updated
---> Package ypbind.x86_64 3:1.19-12.el5_6.1 set to be updated
---> Package yum.noarch 0:3.2.22-39.el5.centos set to be updated
---> Package yum-dellsysid.x86_64 0:2.2.27-3.2.el5 set to be updated
---> Package yum-fastestmirror.noarch 0:1.1.16-21.el5.centos set to be updated
---> Package zlib.x86_64 0:1.2.3-4.el5 set to be updated
---> Package zlib-devel.x86_64 0:1.2.3-4.el5 set to be updated
--> Running transaction check
--> Processing Dependency: dbus = 1.1.2-15.el5_6 for package: dbus-libs
--> Processing Dependency: nash = 5.1.19.6-68.el5_6.1 for package: mkinitrd
---> Package perl-Mail-Sendmail.noarch 0:0.79-1.2.el5.rf set to be updated
base/filelists                                                                                                                                                                        | 3.5 MB     00:00     
dell-omsa-indep/filelists                                                                                                                                                             | 195 kB     00:01     
dell-omsa-specific/filelists                                                                                                                                                          | 1.0 kB     00:00     
extras/filelists_db                                                                                                                                                                   | 224 kB     00:00     
rpmforge/filelists                                                                                                                                                                    | 4.8 MB     00:06     
updates/filelists_db                                                                                                                                                                  | 715 kB     00:00     
--> Finished Dependency Resolution
dbus-libs-1.1.2-15.el5_6.i386 from installed has depsolving problems
  --> Missing Dependency: dbus = 1.1.2-15.el5_6 is needed by package dbus-libs-1.1.2-15.el5_6.i386 (installed)
mkinitrd-5.1.19.6-68.el5_6.1.i386 from installed has depsolving problems
  --> Missing Dependency: nash = 5.1.19.6-68.el5_6.1 is needed by package mkinitrd-5.1.19.6-68.el5_6.1.i386 (installed)
Error: Missing Dependency: nash = 5.1.19.6-68.el5_6.1 is needed by package mkinitrd-5.1.19.6-68.el5_6.1.i386 (installed)
Error: Missing Dependency: dbus = 1.1.2-15.el5_6 is needed by package dbus-libs-1.1.2-15.el5_6.i386 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

I have tried running package-cleanup --dupes and package-cleanup --problems but to no avail.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Sounds like dbus-libs.i386 and nash.i386 are installed. Remove them.

share|improve this answer
    
But nash.i386 is a dependency of mkinitrd. Is mkinitrd something that is needed at boot? –  Hengjie Apr 10 '12 at 6:06
    
It's needed on kernel update. Make sure that you have nash.x86_64 installed. –  Ignacio Vazquez-Abrams Apr 10 '12 at 6:07
    
By kernel update, do you mean only compiling a kernel? Do I need it for CentOS yum kernel updates? –  Hengjie Apr 10 '12 at 8:15
    
You need it for updating via yum. You may need it if you compile your own kernel. –  Ignacio Vazquez-Abrams Apr 10 '12 at 8:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.