Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I found about a dozen questions like this, read them all, but still can't find the problem.

I have a dedicated server running SQL Server 2008 R2 express. I enabled TCP/IP, added firewall exceptions, enabled mixed authentication, started SQL Browser.

I can connect to this database server from my home computer.

But from my work computer, I can't. I can, however, connect to RDP, I can telnet 1433 and get a response. I tried connecting from work to another sql server 2008 r2 and worked.

Any ideas?

share|improve this question
up vote 0 down vote accepted

Are you using sql server auth, or integrated windows auth?

If you can telnet, another thing to do, on the problem client, is to specify the port when connecting in SQL Management Studio:

< remote computer >,1433

Lastly, check the errorlog of the sql server. It will say something like "listening on port ###" Make sure that SQL is really listening on 1433 (and not something else...)

share|improve this answer
I connect using sql server auth. The port sql server is listening to is 1433. If I put "name\instance,1433", it's working!!! Thanks a lot man! – ra00l Apr 10 '12 at 7:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.