Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Context

I have an Oracle 11g database instance and a SQL Server 2012 instance installed on 2 different servers in the same domain. The Oracle database is configured to accept connection with Integrated Security (ie. Active Directory authentication). SQL Server has the Reporting Services feature installed and configured. Reporting Services will connect to Oracle database using the Oracle .NET data provider from Microsoft.


Issue

When creating a data connection to the database in Visual Studio I have no problem to connect to the Oracle database using Integrated Security. I configured the connection with this connection string:

Data Source=INSTANCE_NAME;Integrated Security=True;Unicode=True

But whenever I try to create a data source in Reporting Services from the SSRS website, from Report Builder or from BIDS, I am getting a login error:

ORA-01017: invalid username/password; logon denied

I tried copying the exact same connection string but the result is always the same. It looks like Reporting Services is ignoring the Integrated Security=True option for an unknown reason.


Notes

The same issue occurs with SQL Server 2008 R2.

Oracle .NET data provider from Oracle cannot be used with Reporting Services.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

This is by design and can be researched by searching for Kerberos and double hop issue. You need to enable Kerberos delegation on your reporting services server as well as set up an SPN so that Kerberos can pass the credentials of the user running the report instead of the Service Account for SSRS.

share|improve this answer
    
Interesting, I am gonna investigate on that. Does that means that SSRS is unable to directly retrieve user credentials? –  Ucodia Apr 11 '12 at 7:18
    
Now that I read articles concerning NTLM and Kerberos it seems obvious why it does not work with NTLM. I will come back with links and an answer validation if it resolves my issue. Much thanks. –  Ucodia Apr 11 '12 at 7:38
    
No problem, good luck. –  Jason Cumberland Apr 13 '12 at 16:58
    
Ok so it was only about adding SPN on the report server to make it work. But be informed that only Oracle Enterprise edition can accept Kerberos connections... Thanks for the help. –  Ucodia Apr 25 '12 at 13:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.