Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've deleted a mailbox and it's user in Exchange 2010. Now I'm getting the following warnings in the event log of the Exchange server:

Unable to update Mailbox SD in the DS. Mailbox Guid: a36def77-4743-471b-b67c-60a72f3f4f86. Error Code 0x8004010f

I've tried locating the mailbox by it's GUID, using the method described in this KB from MS:

http://support.microsoft.com/kb/555433

I can't find any corresponding mailbox, which is why I suspect that the GUID belonged to the deleted mailbox. The user who had the mailbox attached is deleted as well.

To make things worse I've also tried to use the primary mail adress of the deleted mailbox for a newly created distribution list, but that won't work. Users trying to mail that adress receive an NDR stating 5.1.1.

It seems like the mailbox somehow lives inside the Exchange server, but I really don't understand how or why.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

go into your Exchange Management shell and run this Cmdlet in powershell

get-mailbox -identity c0fd0fe3-8334-4ca2-8b8d-5488bed375f0 | ft displayname

(replace with your GUID)

if exchange still has it in there, and the users name comes up this will tell you definitively that there was a disconnect from exchange the the deletion.

if it does find the user, you can always try

remove-mailbox -identity c0fd0fe3-8334-4ca2-8b8d-5488bed375f0
share|improve this answer

I found that we'd get this error where a mailbox had been moved to another database (leaving a soft deleted mailbox in the the database) and then the moved mailbox had also been disabled. The guid given couldn't be found using get-mailbox (becasue the mailbox has been disabled) but both the disabled and the soft-deleted mailboxes could be found using get-mailboxdatabase | get-mailboxstatistics | where {$_.Identity -match "c0fd0fe3-8334-4ca2-8b8d-5488bed375f0"}.

You can then use Remove-StoreMailbox -Database $_.database -Identity $_.mailboxguid -MailboxState SoftDeleted -confirm:$false to remove the soft-deleted one.

share|improve this answer

I thought I'd just update on how I solved the situation:

The problematic mailbox had previously been attached to a user who was still in the system, so I created a new mailbox for that user and then detached it. When I did that, two mailboxes appeared in the list of detached mailboxes , one of them being the "ghost" mailbox. I deleted both of them and the problem was solved.

It bothers me somewhat that this happened and that I can't explain it, but the important thing is that the problem was solved for now at least.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.