Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We've been using OpenFire for a while to run a Jabber server for our company. The other day we went to make an account for a new employee and found ourselves mysteriously locked out of the admin panel.

I've reset the admin password and tried multiple accounts. The accounts are able to login to the server using a jabber client, so I know that the passwords we are using are correct.

Anyone know how we might get logged in?

"Login failed: make sure your username and password are correct and that you're an admin or moderator."

Additional Information:

Windows Server 2008 R2

Internal database

Attempted using Setup Mode to see if it would reset anything

Restarted both the server program and the machine itself

Eventual Solution: I eventually just re-installed OpenFire and re-created everyone's accounts. Not the best solution in the world, but it worked. I have edited this post instead of suggesting this as a solution as it didn't really fix the problem so much as make the problem irrelevant.

share|improve this question
1  
Are you on a Linux or Windows server? Are you running the internal database or an external database? –  Wesley Apr 10 '12 at 19:45
    
Additional Information: We are running on Windows Server 2008 R2. Currently we are using an internal database. I have restarted the server a number of times in my attempts to solve this problem. I also modified the configuration file to put the server into setup mode once, to see if going through the setup would solve the issue. –  Zell Faze Apr 10 '12 at 19:55
    
I updated my answer for Windows, but obviously it's not the answer to your particular situation. I'll keep it up because it might be an answer to someone's problem in the future. –  Wesley Apr 10 '12 at 20:40
    
This will keep coming back forever and ever until you accept an answer. You are allowed to answer your own question and accept the answer. –  Michael Hampton Jul 30 '12 at 17:39

2 Answers 2

up vote 2 down vote accepted

Do you have shell access to the server? As silly as it sounds, openfire likes to be restarted once in a while. For Linux:

service openfire restart

or

/etc/init.d/openfire restart

For Windows:

Go into services.msc and restart OpenFire services. Some report that a full server reboot works better.

share|improve this answer

I would check file permissions too. Typically when we have had issues with permissions (though on Linux) restarting openfire would go through the setup wizard upon restart, so it may not be exactly the same...but worth a shot :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.