Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I installed WAMP server 2.2 on Windows 7 x64. I clicked on its system tray icon and put the server online. Then I select PhpMyAdmin and I get a 404 page.

Localhost successfully gives me the Apache 2 test page. There's no way I'm able to fix this. The PHP error log and the Apache error logs have no errors.

Note: I've tried all combinations of the url such as localhost/phpmyadmin/ and localhost/phpmyadmin and localhost/phpmyadmin/?

share|improve this question

closed as off-topic by EEAA, 84104, masegaloeh, Jenny D, Scott Pack May 6 at 2:13

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions on Server Fault must be about managing information technology systems in a business environment. Home and end-user computing questions may be asked on Super User, and questions about development, testing and development tools may be asked on Stack Overflow." – EEAA, 84104, masegaloeh, Jenny D, Scott Pack
If this question can be reworded to fit the rules in the help center, please edit the question.

And you are certain that phpMyAdmin is served on port 80? – Mathias R. Jessen Apr 10 '12 at 21:17
I didnt change anything. All I did was install and run. How can i find the port its running on? – Urban Apr 10 '12 at 21:19
Isn't there a shortcut to phpMyAdmin if you click on the wampserver icon in the system tray? – Mathias R. Jessen Apr 10 '12 at 21:21
ok it seems I had to uninstall my previous installation of mysql server and then re-install wamp. The server is fixed now but Im getting access denied at phpMyAdmin for MySQL. – Urban Apr 10 '12 at 21:23

3 Answers 3

I was just having this problem and i've come across an easier solution:

left click on the wamp tray icon apache> apache modules> check the 'rewrite module'


share|improve this answer
up vote 1 down vote accepted

Ok, well first I had to un-install my previous installation of the MySQL server. This fixed the wamp server which now ran perfectly.
A different issue also cropped up later (not related directly to question). I was getting access denied on the phpMyAdmin page. This I could fix by changing $cfg['Servers'][$i]['nopassword'] = false; to $cfg['Servers'][$i]['nopassword'] = true;
The above lines are in C:\wamp\apps\phpmyadmin3.2.0.1\libraries and search for config.default.php

share|improve this answer


Make sure that nothing else is using port 80. Check netstat -abn to see what is listening on that port.

One of the biggest culprits is Skype. Look under options >> advanced >> connection and see if "use port 80" is checked. Uncheck if so. Then restart Skype. Might have to restart WAMP too.

Next would be any anti-virus / anti-spam / anti-functionality software. Temporarily disable it to test. If everything works, re-enable it and figure out what portion of the software is blocking the connection.

Check to see if IIS is installed and uninstall it.


Check your directory structure. Open up your web root and make sure that a phpmyadmin folder exists, and also exactly what case its typed in.

share|improve this answer
I had to un-install my previous installation of MySQL server and then re-install wamp to make it work. Now the wamp server works fine but Im getting an access denied at phpMyAdmin. I thinks thats a totally different issue. – Urban Apr 10 '12 at 21:27
@Urban Thanks for the update! – Wesley Apr 10 '12 at 21:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.