Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm working towards disabling Netbios over TCP/IP for my organization. I've created a reservation for my MAC address. I can see that the reservation becomes active when I renew my IP address. I set option 001 under the Microsoft Options vendor class and the Default BOOTP class with a value of 0x2. When I renew my IP address, the DHCP server never adds this option to the DHCP Offer or DHCP ACK.

How do I need to configure the options in order to get this functioning properly?

share|improve this question
    
Did you apply that option only to the specific reservation? Also, have you confirmed in the raw DHCP packets that the option isn't being set? –  Shane Madden Apr 11 '12 at 18:50
    
I applied it only to that reservation. I did not see the option set in the raw packets. –  bshacklett Apr 11 '12 at 18:52
    
What DHCP server are you using? –  Harry Johnston Apr 14 '12 at 23:52
    
Windows DHCP services. –  bshacklett Apr 15 '12 at 4:53
    
Make that Windows 2003 DHCP services. –  bshacklett Apr 16 '12 at 14:31
add comment

2 Answers

up vote 1 down vote accepted

I believe the problem in my case was due to an incorrect User class being specified. I had run ipconfig /showclassid "Local Area Connection", which gave me the following output:

Windows IP Configuration

DHCPv4 Classes for Adapter "Local Area Connection":

   DHCPv4 ClassID Name . . . . . . . . : Default Routing and Remote Access Class
   DHCPv4 ClassID Description  . . . . : User class for remote access clients

   DHCPv4 ClassID Name . . . . . . . . : Default BOOTP Class
   DHCPv4 ClassID Description  . . . . : User class for BOOTP Clients

I thought, from this output, that I should have been using the Default BOOTP Class. After reconfiguring the options for the Default User Class, however, everything appears to be working now. Currently I have the option set in both the Microsoft Options vendor class as well as the Microsoft Windows 2000 vendor class.

It's interesting to note that a Wireshark capture still does not show the DHCP option being set. It seems that Wireshark displays this data under a Vendor-Specific Information "parent" option, but I can't be certain at this point.

share|improve this answer
add comment

The option I would use would be simply not to configure any WINS servers in my DHCP server options.

I noticed that the description of the item you mentioned says, "Option for enabling or disabling Netbios for Microsoft Windows 2000 Clients." It would seem not to apply to anything more recent than Windows 2000.

share|improve this answer
    
If no WINS servers are configured, Windows will fall back to broadcast resolution, which is not something I would like to experience with 2000 or so hosts on a network with multiple subnets. –  bshacklett Apr 17 '12 at 18:49
    
There is definitely a DHCP option to control NetBIOS over TCP/IP on current Windows versions. We're using it here, although we have a Linux-based DHCP server. –  Harry Johnston Apr 17 '12 at 22:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.