Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running Ubuntu 11.10. I have a local application that is trying to receive multicast UDP streams via an OpenVPN tunnel. I have network connectivity to the remote host that is generating the multicast data and can access that host properly. In addition, if I fire up Wireshark on my local machine, it is able to see the UDP packets coming through with the designated multicast destination addresses. However, my client application isn't indicating that it has received any data, so I'm trying to figure out the reason why.

Is there a simple tool that I can use at the command line to verify that the multicast traffic is being passed through to the user level? I'm wondering if there is something between Wireshark and userland that is filtering the packets for some reason. I've also tried using tcpdump as follows:

sudo tcpdump -n -i tap0 -s 1536 udp

When I run this command, I also see messages fly by showing reception of the packets as I would expect. I'm not too familiar with the innards of tcpdump, however; I'm not sure if it's also peeking down further under the hood than a typical user application would. Any suggestions?

share|improve this question
1  
use ip maddr to check you've actually assigned the multicast address to the machine. –  Olipro Apr 11 '12 at 20:43
    
I tried doing a ip maddr add 224.0.1.1 dev tap0, and the command seems to execute successfully, but when I subsequently do a ip maddr show, the multicast address isn't shown under tap0. –  Jason R Apr 11 '12 at 20:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.