Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm getting this error on my PC:
frequency error -1732 PPM exceeds tolerance 500 PPM

Any ideas?

share|improve this question

2 Answers 2

up vote 5 down vote accepted

This means that the difference between your local time and the server you're syncing with has exceed ntpd's limit. ntpd will only sync the local time if it is relatively close to the time server. This is why Red Hat (as an example) uses ntpdate the first time you start the ntpd service to set the local time to be in the right ball park. You should also make sure that the ntp servers you are syncing with are relatively close.

You can do these steps manually if you want (e.g. you're not running Red Hat which includes the ntpdate step in it's restart script):

# /etc/init.d/ntpd stop
# ntpdate <ip address of time server>
# /etc/init.d/ntpd start

However, if you're seeing these errors in a log file for a machine that has been up sometime and it is a virtual machine then there may be a different issue at play. Virtual Machines have problems with their time because there isn't a proper hardware timing signal coming in. Follow VMWare's advice found here (it is equally relevant for other virtualisation platforms):

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1006427

http://www.vmware.com/files/pdf/Timekeeping-In-VirtualMachines.pdf

Or NTP's advice here:

http://twiki.ntp.org/bin/view/Support/KnownOsIssues#Section_9.2.2.

Microsoft Hyper V docs reference the VMWare stuff above for when running Linux on their virtualisation platform.

share|improve this answer
    
But it happens on my PC, not under VM –  user626528 Apr 12 '12 at 11:39
    
Then see the first part of the answer. You need to set your time to be closer to the time server's time. Assuming this is a server, then use ntpdate to do the initial sync, then start ntpd. I'll update my answer to have these steps explicitly stated. –  webtoe Apr 12 '12 at 11:50

You tagged this with "Windows", so I am assuming you are running the reference implementation of ntpd under Windows using the installer from Meinberg.

Meinberg suggests the following command line args

ntpd.exe -U 3 -g -M 

-g lets it make a big jump on launch, avoiding the need to run ntpdate. The -M option (Windows-specific) adjusts the "multimedia timer" setting to avoid problems when other applications access this timer. However I found one machine where ntpd simply would not work right with the -M option; offset and jitter started small but increased without bound. After removing that option it works fine. So if you find the feedback loop won't close under Windows, try changing the state of the -M option.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.