Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm configuring CentOS 6.2 and have seen a few "[abrt] full crash report" emails. I understand that abrt is useful for creating crash dumps and what not, so I don't want to disable the service, I just would like to stop getting the crash report emails.

I probably have to add something to the config file in /etc/abrt/abrt.conf. I can't seem to find anything in my searches. Any idea? Thanks.

Edit:

Here is my abrt.conf, which is rather simple.

[root@myhost~]# cat /etc/abrt/abrt.conf
# Enable this if you want abrtd to auto-unpack crashdump tarballs which appear
# in this directory (for example, uploaded via ftp, scp etc).
# Note: you must ensure that whatever directory you specify here exists
# and is writable for abrtd. abrtd will not create it automatically.
#
#WatchCrashdumpArchiveDir = /var/spool/abrt-upload

# Max size for crash storage [MiB] or 0 for unlimited
#
MaxCrashReportsSize = 1000

# Specify where you want to store coredumps and all files which are needed for
# reporting. (default:/var/spool/abrt)
#
#DumpLocation = /var/spool/abrt

And a listing of /etc/abrt:

[root@myhost~]# ls -la /etc/abrt
total 32
drwxr-xr-x.  3 root root  4096 Apr 13 06:14 .
drwxr-xr-x. 97 root root 12288 Apr 13 03:50 ..
-rw-r--r--.  1 root root   527 Dec 13 22:50 abrt-action-save-package-data.conf
-rw-r--r--.  1 root root   572 Dec 13 22:50 abrt.conf
-rw-r--r--.  1 root root   175 Dec 13 22:50 gpg_keys
drwxr-xr-x.  2 root root  4096 Apr 13 06:13 plugins

[root@myhost~]# ls -la /etc/abrt/plugins/
total 12
drwxr-xr-x. 2 root root 4096 Apr 13 06:13 .
drwxr-xr-x. 3 root root 4096 Apr 13 06:14 ..
-rw-r--r--. 1 root root  278 Dec 13 22:50 CCpp.conf

Actually all of those conf files above are only a few lines and do not mention anything about mail, email, or notifications.

UPDATE

Since I have disabled abrtd, I've been seeing these in /var/log/messages:

myhost abrt: abrt daemon is not running. If it crashed, /proc/sys/kernel/core_pattern contains a stale value, consider resetting it to 'core'

The proper way to stop the abrt service is:

service abrt-ccpp stop
chkconfig abrt-ccpp off
share|improve this question
    
I assume you are getting emails/notifications locally on the host at the command line, and not in an actual external mailbox? –  WerkkreW Apr 12 '12 at 18:48
    
The emails are sent from the "user" user to the "root" user. Postfix is configured to hand off any mail to our mail relay server, and anything going to root forwards to my email address (per /etc/aliases). Does that answer your question? –  Banjer Apr 12 '12 at 19:11
add comment

2 Answers

up vote 3 down vote accepted

I have the same problem running RHEL 6.2. It seems that Mailx wasn't a separate module in the version of abrt being used. I found the best way is to either blacklist programs by adding it to /etc/abrt/abrt-action-save-package-data.conf:

BlackList = program1, program2, program3

(followed by service abrtd restart)

Or by disabling abrt all together:

# chkconfig abrtd off

(followed by service abrtd stop)

share|improve this answer
    
I disabled abrt completely. I'll keep the Blacklist conf in mind though, thanks. –  Banjer May 2 '12 at 15:33
add comment

You're likely receiving these because the mailx plugin for abrtd has been installed. There are a number of different ways it could be invoked, so what you need to do is look in your /etc/abrt/abrtd.conf file for instances of the string "Mailx" and remove those lines. For example, you may see:

ActionsAndReporters = Mailx("[abrt] a crash occurs") 

which tells abrtd to email out a report on every crash, or you could see

CCpp:httpd = Mailx("[abrt] Apache crash") 

which causes abrtd to email out an alert whenever the process httpd crashes.

So look through your config file for any such instances of Mailx being invoked, remove then, restart abrtd, and you should be fine.

share|improve this answer
    
Thanks for the reply. I added some more info to my question, but unfortunately I do not see anything about mail in the conf files. –  Banjer Apr 13 '12 at 10:18
    
@Banjer the right place to look is /etc/libreport/events.d/abrt_event.conf. I found that place by invoking rpm -qc abrt. –  Nils Dec 18 '13 at 15:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.