Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have this command in crontab:

wget --quiet --delete-after http://boms.ro/admincp/cron/s/9abf0f42c1e4f55fdb87d8237cdde

And when I run it with the --debug argument I get the following response:

Caching boms.ro => 188.240.2.30
Created socket 3.
Releasing 0x00000000010c97e0 (new refcount 1).

---request begin---
GET /admincp/cron/s/9abf0f42c1e4f55fdb87d8237cdde HTTP/1.0
User-Agent: Wget/1.12 (linux-gnu)
Accept: */*
Host: boms.ro
Connection: Keep-Alive

---request end---

---response begin---
HTTP/1.0 406 Not Acceptable
Date: Thu, 12 Apr 2012 18:29:45 GMT
Server: LiteSpeed
Connection: Keep-Alive
Keep-Alive: timeout=5, max=100
Cache-Control: private, no-cache, max-age=0
Pragma: no-cache
Content-Type: text/html
Content-Length: 372

---response end---
Registered socket 3 for persistent reuse.
Skipping 372 bytes of body: [<html>
<head><title> 406 Not Acceptable
</title></head>
<body><h1> 406 Not Acceptable
</h1>
This request is not acceptable<hr />
Powered By <a href='http://www.litespeedtech.com'>LiteSpeed Web Server</a><br />
<font face="Verdana, Arial, Helvetica" size=-1>LiteSpeed Technologies is not responsible for administration and contents of this web site!</font></body></html>
] done.

What is considered "not acceptable" in my request?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

I'm seeing some references around that the mod_security (probably a bad included rule?) included with that "LiteSpeed" server package might be the cause.

Try disabling mod_security - and as an aside, that's a pretty weak usage of the 406 response code if that's the case.

share|improve this answer
    
That was the problem. I sent a ticket to the hosting provider and they disabled it. –  sica07 Apr 12 '12 at 19:05
add comment

The meaning of 406 Not Acceptable is that your client (in this case either wget or a proxy) sent an Accept: header, but the server is unable to send the document in a format listed in the Accept: header it got. Accept-* headers also cause the same behaviour.

Because your accept header is set to accept any MIME type and isn't including requests for specific languages or anything, this is probably a bug in the http server (or the CGI application it is running).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.