Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

The Internet Explorer Enhanced Security (IEES) won't disable using the normal method of disabling it from the Add/Remove Programs/Windows components. This came to light immediately after testing.

IEES was disabled after Terminal Services were installed for admin and users, and after IE8 was installed. My initial thoughts were that there was some clash between IE8 and IE6 (which is the default on 2003 R2), so I uninstalled IE8 and reverted back to IE6. The same symptoms were displayed, when a normal user logged on Internet Explorer Enhnaced Security was enforced.

I then thought it could be a problem that Terminal Server wasn't recognising the removal as IEES was on when initially installed. I uninistalled the Terminal Server Componants using the server roles, and then reactivated and deavtived IEES. Windows Server 2003 R2 allows a limited number of users to connect to RDP by default, so I logged on as a normal user, and IEES was disabled.

I then reinstalled Terminal Server, and logged on as a normal user. IEES was back enabled.

Why is this?

share|improve this question
    
I've posted this qestion as it has taken me ages to track down why it isn't working correctly. There are a couple of other questions like this, but they don't fix the issue in terminal server. –  Tubs Apr 13 '12 at 9:39

1 Answer 1

up vote 1 down vote accepted

Terminal server has it's own registry settings for Internet Explorer Enhanced Security on Windows 2003 R2 (this does not seem to affect Windows 2003 standard)

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\TerminalServer\Install\Software\Microsoft\Windows\CurrentVersion\InternetSettings\ZoneMap]

And make sure that "IEHarden" is set to 0

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.