Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Linux storage device (QNAP TS-459U), and 'massive1' folder shared. I need to mount this share on my Debian server. They are connected by regular patch cord. The Debian server has two network interfaces - eth0 and eth1. eth0 is for Internet, eth1 is for QNAP.

So, I'm saying this:

mount -t cifs //169.254.100.100/massive1/ /mnt/storage -o user=admin,

where 169.254.100.100 is an IP of QNAP's interface. The result I get (after entering password):

 mount error(14): Bad address
 Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Tried: mount.cifs, smbmount, with '/' at the end of the network share and without it, and many other variations of that command. And always it's: mount error(14): Bad address

Funny thing is when I was in Data Center, I had connected my netbook to QNAP by the same scheme (with Fedora 16 on it), and it connected without any problems, I could read/write files on the QNAP's NAS share!

So I'm really stuck with the Debian. I can't undrestand where's the difference with Fedora, making this error. Yeah, I've used Google. Couldn't find any useful info.

Ping to the QNAP's IP is working, I can log into QNAP's Linux by ssh, telnet on 139's port is working.

This is network interface configuration I use in Debian:

IP: 169.254.100.1 Netmask: 255.255.0.0

The only diffence in connecting to Fedora and Debian is that in Fedora I've added gateway - 169.254.100.129, but ping to this IP is not working, so I think it's not necessary at all.

~# cat /etc/debian_version
wheezy/sid

~# uname -a
Linux host 2.6.32-5-openvz-amd64 #1 SMP Mon Mar 7 22:25:57 UTC 2011 x86_64 GNU/Linux

~# smbtree

WORKGROUP
        \\HOST                         host server
                \\HOST\IPC$            IPC Service (host server)
                \\HOST\print$          Printer Drivers

NAS
        \\MASSIVE1                      NAS Server
                \\MASSIVE1\IPC$                 IPC Service (NAS Server)
                \\MASSIVE1\massive1
                \\MASSIVE1\Network Recycle Bin 1        [RAID5 Disk Volume: Drive 1 2 3 4]
                \\MASSIVE1\Public               System default share
                \\MASSIVE1\Usb                  System default share
                \\MASSIVE1\Web                  System default share
                \\MASSIVE1\Recordings           System default share
                \\MASSIVE1\Download             System default share
                \\MASSIVE1\Multimedia           System default share

Please, help me with solving this strange issue.

share|improve this question

3 Answers 3

Is there any chance you have the QNAP's DHCP-server enabled? If so, that would explain why you were able to obtain an address locally via your laptop (zeroconf, maybe). Can you assign the QNAP and your network a proper local address scheme?

See: http://en.wikipedia.org/wiki/Private_network#Private_IPv4_address_spaces

share|improve this answer
    
Okay, I've set up QNAP's network interface with IP 192.168.100.100/24, and the debian IP - 192.168.100.1/24. Result is the same - Bad address. –  Korben Apr 16 '12 at 4:21
    
By the way, using 169.254.100.100 and 169.254.100.1 IPs described in the installation guide book for QNAP, so it must work. The reason is 100% in Debian, but what's wrong, I can't get. –  Korben Apr 16 '12 at 5:44

169.254.x.x is a link-local address. All addresses from 169.254.1.0 to 169.254.254.255 are. I'm not surprised this configuration doesn't work, this is the address a NIC gets when it is unable to get an IP from DHCP.

Try configuring some static IP's and try again.

share|improve this answer
    
But why it worked in Fedora? And why it's pingable? I can't understand. –  Korben Apr 13 '12 at 12:27
    
I think I know, why it worked on my laptop. It's because it has only one network adapter, when the server has two interfaces. I think the reason is in routing. –  Korben Apr 16 '12 at 6:29
    
Installed CentOS and everything became fine. –  Korben Apr 18 '12 at 13:02

The mount statement which worked for me in Debian squeeze is this one

mount -t nfs {remote_machine_IP_address}:/{share_point} {local_mount_point}

and to unmount it

umount -t nfs {local_mount_point}

(making sure that no other process is using this mount point of course!)

However you will need to set up permissions and share points on the QNAP NAS first and open NFS access.

However, when I used this on a share point I had set up, I could not see the files and folders underneath, but the mount worked which is the point of this post.

QNAP forum is good too http://forum.qnap.com/index.php

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.