Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a VPS running Fedora 16 (upgraded from 15). Mysql was installed and working until recently.

Now I can't get the mysql service started.

when I try

/etc/init.d/mysqld start

I get the error

/etc/init.d/mysqld: No such file or directory

I have uninstalled and installed mysql several times

yum install mysql mysql-server

but the service still isn't available

share|improve this question
    
make sure it is installed rpm -q mysql-server –  Mike Apr 13 '12 at 13:03
    
running rpm -q mysql-server gives me the following: mysql-server-5.5.21-1.fc16.x86_64 –  Pierre Apr 13 '12 at 13:05
    
rpm -ql mysql-server ? Just show the full package listing. That should be the package, though Distrowatch has it at version 5.5.19, not .21. –  cjc Apr 13 '12 at 13:46
    
I don't have an FC16 install lying around, but could they be using Upstart for mysql? In that case, you'll see something in /etc/init. In that case, the service startup will be "service mysql start" (or "service mysqld start", depending on what's in the /etc/init directory). –  cjc Apr 13 '12 at 13:48
    
Forget about the Upstart suggestion. They're using "systemd" on Fedora 15 and up. fedoraproject.org/wiki/Systemd So, mysql could be controlled by systemd, with the attendant systemctl commands. –  cjc Apr 13 '12 at 13:51

2 Answers 2

sometimes the service is called mysql instead of mysqld. maybe you can try that. do an ls of /etc/init.d to show what is actually there.

share|improve this answer
    
No, it's called mysqld on my CentOS box. –  cjc Apr 13 '12 at 13:44
    
well, on my centos the init script is called mysql sometimes. do you see anything if you do ls /etc/init.d/mysql*? how about rpm -ql mysql-server? this will show you what files were actually installed. if you cannot find the init script then the install is corrupt. you may want to download packages from mysql.com and install yourself to fix that. mysql.com/downloads/mysql select redhat version. –  johnshen64 Apr 13 '12 at 13:45
    
@johnshen64 I downloaded and installed MySQL directly from their site, and now it works perfectly, thanx. –  Pierre Apr 16 '12 at 6:15

Fedora has switched to using systemd. There is no mysqld init script any more; instead there is a systemd control file. On Red Hat/Fedora you typically use service mysqld (restart|start|stop) rather than the actual init scripts and this now warns you of the change.

The service and chkconfig commands have been fitted with code to make systemd calls for services that have been switched. You should start getting used to the new systemd way of doing things by using the straight systemctl command to deal with services such as:

# To see the status of mysqld
$ systemctl status mysqld.service
mysqld.service - MySQL database server
  Loaded: loaded (/lib/systemd/system/mysqld.service; disabled)
  Active: inactive (dead)
  CGroup: name=systemd:/system/mysqld.service

# To start mysqld
$ systemctl start mysqld.service
$ systemctl status mysqld.service
mysqld.service - MySQL database server
  Loaded: loaded (/lib/systemd/system/mysqld.service; disabled)
  Active: active (running) since Fri, 13 Apr 2012 15:58:16 +0100; 2s ago
 Process: 4776 ExecStartPost=/usr/libexec/mysqld-wait-ready $MAINPID (code=exited, status=0/SUCCESS)
 Process: 4637 ExecStart=/usr/bin/mysqld_safe --nowatch --basedir=/usr (code=exited, status=0/SUCCESS)
 Process: 4622 ExecStartPre=/usr/libexec/mysqld-prepare-db-dir (code=exited, status=0/SUCCESS)
Main PID: 4775 (mysqld)
  CGroup: name=systemd:/system/mysqld.service
      └ 4775 /usr/libexec/mysqld --basedir=/usr --datadir=/var/lib/mysql -...

# Enable the service over reboots (which just sets up some symlinks in the relevant dirs). 
# Analogous to "chkconfig mysqld on"
$ systemctl enable mysqld.service
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.