Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

hello I need a socks5 proxy for debian with simple configuration. dante not working. p.s: I do NOT wish to use SSH tunneling.

share|improve this question
2  
note that lenny is EOL and no longer supported. It has well known security vulnerabilities that nobody is going to fix. It is recommended you upgrade to squeeze (by following chapter 4 of the squeeze release notes). –  stew Apr 13 '12 at 16:05
add comment

1 Answer

Dante on lenny seems to be a known issue. try

nano /etc/apt/sources.list (change "lenny" to "etch" )

apt-get update

apt-get install dante-server

nano /etc/apt/sources.list (change "etch" back to "lenny")

apt-get clean

And make sure you configured dante correctly (the default config should fail)

As an alternative you could use sockd, check out apt-get install socks4-server & man sockd

Or when v5 is a must take a look at tsocks

share|improve this answer
    
not works .............. –  m3hdi Apr 13 '12 at 16:30
1  
deeper? logs logs logs... "not works" as in "i can connect but cant reach the internet anymore" or as in "when i press enter on the start command my computer explodes, northkorea fixes the missle thing and your gradfather starts running arround naked"? –  Tabakhase Apr 13 '12 at 16:37
    
apt-get failed and can not get package –  m3hdi Apr 13 '12 at 17:29
    
E: Couldn't find package dante-server –  m3hdi Apr 13 '12 at 17:42
    
update.your.system. thx =( (you notice a ton of 404s when doing apt-get update, dont you?) –  Tabakhase Apr 13 '12 at 18:27
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.