Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm using Message Tracking in Exchange 2007, but I don't think emails coming from outside are being logged. I can run a query and see messages internal to the domain, but I get no results when trying to find messages that were sent from outside the domain to someone in the org. Is this enabled by default? Where is this setting controlled?

share|improve this question

1 Answer 1

In Exchange 2007 you cannot modify the message tracking settings in the Exchange Management Console (EMC). You have to use the Exchange Management Shell (EMS):

Check to see if message tracking is turned on with this PowerShell command:

Get-MailboxServer [servername] | fl *messagetracking*

Turn it on with:

Set-TransportServer [servername] –MessageTrackingLogEnabled $true

Message tracking can only be configured on Exchange servers that have the Hub Transport, Edge Transport or Mailbox roles.


EDIT 1

Since message tracking is enabled, but doesn't appear to be logging external mail, let's try a few things.

Test your server health and post the results in your original post. In the EMS, run the following two cmdlets:

Test-ServiceHealth
Test-SystemHealth

Check your event logs for any Exchange related errors. I'm interested in seeing if the log files are being properly written to.

A slightly scorched earth possibility that I've heard of is to disable message tracking, disable Exchange services that are pertinent, move the tracking log to a new folder, and restart Exchange services thus creating a new log file.

The default location for message tracking logs is: Drive:\Program Files\Microsoft\Exchange Server\TransportRoles\Logs\MessageTracking

(Disclaimer! Do the following at your own risk!)

  1. Disable message tracking Set-TransportServer [servername] –MessageTrackingLogEnabled $false (Make sure you're on the hub transport server!)
  2. Stop the following services: Transport, Mail Submission and Exchange Transport Log Search services.
  3. Move the existing message tracking log files to a new folder.
  4. Restart the services that you stopped in step two.
  5. Re-enable message tracking Set-TransportServer [servername] –MessageTrackingLogEnabled $true
share|improve this answer
    
It's enabled, but I'm still not seeing messages coming from outside. –  MathewC Apr 13 '12 at 18:41
    
@MathewC Updated my answer –  Wesley Apr 13 '12 at 18:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.