Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been learning PHP. I had installed Apache-server (not in a combination-suite like USBWebserver). Now I'm trying to put my sites on a portable stick, using USBWebserver. I already used that program before to carry MySQL databases with me (and Apache worked as well, cause I used the included PHPMyAdmin for managing the databases.), but now it doesn't work anymore. When I start the program, I keep having the text saying Apache is offline.

I've tried to open Apache using the command line (don't know what that would do, but, it's just a try). I got an error message saying

Syntax error on line 494 of C:/.../httpd.conf: Cannot load C:/.../php5apache2_2.dll into server:
(The following is translated from Dutch)
An initialization routine of the dynamic link library (dll-file) has failed.

Line 494 says this:

LoadModule php5_module "C:/Users/School/Downloads/USBWebserver v8_en/php/php5apache2_2.dll"

My first Apache installation (its service) is not running. The ports are different. And I also uninstalled the service (using the httpd.exe -k uninstall command);

What can be the problem? Thanks for help.

share|improve this question
up vote 1 down vote accepted

Apache shouldn't start if it's unable to load any of its modules.

Make sure the version of the windows apache PHP library (php5apache*.dll) is built for the version of apache you are using and that it is in the correct path and not corrupt.

share|improve this answer
That can not be the problem, cause USBWebserver has already worked, I also already downloaded a new version, which also didn't work. Thanks for helping though. – pikachu Apr 14 '12 at 20:43
I'm wrong. I changed changed the content of the php directory to that of the php directory downloaded from Now version 8.0 works. In version 8.5, I get errors about extension it can't find (even though the error mentions the right path). – pikachu Apr 23 '12 at 13:25

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.