Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.
  • I have Debian 4 server (i know it is very old)
    cat /etc/issue
    Debian GNU/Linux 4.0 \n \l
    
  • I have the following in /etc/apt/sources.list
    deb http://debian.uchicago.edu/debian/ stable main
    deb http://ftp.debian.org/debian/ stable main
    deb-src http://ftp.debian.org/debian/ stable main
    deb http://security.debian.org/ stable/updates main
    
  • apt-get upgrade
    Reading package lists... Done
    Building dependency tree... Done
    You might want to run 'apt-get -f install' to correct these.
    The following packages have unmet dependencies.
      libt1-5: Depends: libc6 (>= 2.7) but 2.3.6.ds1-13etch10+b1 is installed
      locales: Depends: glibc-2.11-1 but it is not installable
    E: Unmet dependencies. Try using -f.
    
  • Now it shows that i have Debian 6!!
    cat /etc/issue
    Debian GNU/Linux 6.0 \n \l

EDIT
I have tried

apt-get update
Get: 1 http://debian.uchicago.edu stable Release.gpg [1672B] 
Hit http://debian.uchicago.edu stable Release
Ign http://debian.uchicago.edu stable/main Packages/DiffIndex 
Hit http://debian.uchicago.edu stable/main Packages 
Get: 2 http://security.debian.org stable/updates Release.gpg [836B] 
Hit http://security.debian.org stable/updates Release 
Get: 3 http://ftp.debian.org stable Release.gpg [1672B]
Ign http://security.debian.org stable/updates/main Packages/DiffIndex
Hit http://security.debian.org stable/updates/main Packages
Hit http://ftp.debian.org stable Release
Ign http://ftp.debian.org stable/main Packages/DiffIndex
Ign http://ftp.debian.org stable/main Sources/DiffIndex
Hit http://ftp.debian.org stable/main Packages
Hit http://ftp.debian.org stable/main Sources
Fetched 3B in 0s (3B/s)
Reading package lists... Done
apt-get dist-upgrade
Reading package lists... Done 
Building dependency tree... Done 
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies.
  libt1-5: Depends: libc6 (>= 2.7) but 2.3.6.ds1-13etch10+b1 is installed
  locales: Depends: glibc-2.11-1
E: Unmet dependencies. Try using -f.
apt-get -f install
Reading package lists... Done
Building dependency tree... Done
Correcting dependencies...Done
The following extra packages will be installed:
  gcc-4.4-base libbsd-dev libbsd0 libc-bin libc-dev-bin libc6
Suggested packages:
  glibc-doc
Recommended packages:
  libc6-i686
The following packages will be REMOVED
  libc6-dev libedit-dev libexpat1-dev libgcrypt11-dev libjpeg62-dev libmcal0-dev libmhash-dev libncurses5-dev libpam0g-dev libsablot0-dev libtool libttf-dev
The following NEW packages will be installed
  gcc-4.4-base libbsd-dev libbsd0 libc-bin libc-dev-bin
The following packages will be upgraded:
  libc6
1 upgraded, 5 newly installed, 12 to remove and 349 not upgraded.
7 not fully installed or removed.
Need to get 0B/5050kB of archives.
After unpacking 23.1MB disk space will be freed.
Do you want to continue [Y/n]? y
Preconfiguring packages ...
dpkg: regarding .../libc-bin_2.11.3-2_i386.deb containing libc-bin:
 package uses Breaks; not supported in this dpkg
dpkg: error processing /var/cache/apt/archives/libc-bin_2.11.3-2_i386.deb (--unpack):
 unsupported dependency problem - not installing libc-bin
Errors were encountered while processing:
 /var/cache/apt/archives/libc-bin_2.11.3-2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Now: it seems there is a conflict!! how can i fix it? and is it true that the server has became debian 6!!??
Thanks for your help

share|improve this question

1 Answer 1

Your sources.list entries are for stable, which is "squeeze"/6; if you were really using those on a Debian 4 system, you probably have a very confused system now. An apt-get dist-upgrade might be able to bring things into sync (by bringing you up to stable, i.e. Debian 6); you probably can't get your old system back if packages have been overwritten by the "squeeze" packages.

share|improve this answer
    
i dont have a problem of having debian 6... but how can i make the system stable and fix this conflict?? –  Alaa Alomari Apr 15 '12 at 9:03
    
apt-get update; apt-get dist-upgrade will probably do it, if it can be fixed at all. (It may ask you to run apt-get with another option to try to fix any dependencies broken by the use of the wrong sources.) –  geekosaur Apr 15 '12 at 9:14
    
Plz check the question again, i have tried apt-get dist-upgrade –  Alaa Alomari Apr 15 '12 at 9:43
    
I tried to comment on the apt-get -f install but hit the comment edit timeout; it's telling you to run that for a reason. –  geekosaur Apr 15 '12 at 9:49
    
i did apt-get -f install and the question has been edited again :) thanks a lot for your help –  Alaa Alomari Apr 15 '12 at 10:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.