Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Debian based linux server running for a year or so, without any problems. A couple of days ago, ssh interactive mode stopped working for no reason. I mean, I can open an ssh connection just fine, the server greets me with shell but I just can't type anything. However, if I send commands like this: ssh cat /var/log/messages, I get the response.

I dug through several logs and found one message, which feels remotely relevant to the problem;

sh kernel: [10222733.062511] ------------[ cut here ]------------
sh kernel: [10222733.062522] WARNING: at /build/buildd-linux-2.6_2.6.32-39-amd64-7yVIH2/linux-2.6-2.6.32/debian/build/source_amd64_none/drivers/char/tty_ldisc.c:738 tty_ldisc_reinit+0x46/0x7b()
sh kernel: [10222733.062526] Hardware name: PowerEdge R210 II
sh kernel: [10222733.062528] Modules linked in: ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 nf_conntrack nf_defrag_ipv4 ip_tables x_tables sha1_generic arc4 ecb ppp_mppe ppp_async crc_ccitt ppp_generic slhc loop snd_pcm snd_timer snd soundcore snd_page_alloc i2c_i801 i2c_core pcspkr evdev joydev dcdbas container button processor ext3 jbd mbcache sg sd_mod sr_mod crc_t10dif cdrom usb_storage usbhid hid mpt2sas ahci ehci_hcd libata scsi_transport_sas usbcore bnx2 nls_base scsi_mod fan thermal thermal_sys [last unloaded: scsi_wait_scan]
sh kernel: [10222733.062568] Pid: 8662, comm: sshd Not tainted 2.6.32-5-amd64 #1
sh kernel: [10222733.062569] Call Trace:
sh kernel: [10222733.062572]  [<ffffffff811ff056>] ? tty_ldisc_reinit+0x46/0x7b
sh kernel: [10222733.062574]  [<ffffffff811ff056>] ? tty_ldisc_reinit+0x46/0x7b 

Is there any way to get back the sshd working in interactive mode? I tried restarting sshd but that is no help. And somehow, I can not reboot the server. Tried sending shutdown -r now and reboot but it refuses to go down.

Should I go ahead and request a physical reboot?

share|improve this question
up vote 1 down vote accepted

That's going to require a forced reboot, yes; the tty/pty driver has become deranged (ldisc is a shared layer containing the termios stuff and line buffering; on some OSes a different ldisc is used for PPP/dialup networking).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.