Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Is there a source like dotdeb.org which offers the apache 2.4 packages for Debian squeeze? I'm looking for Apache modules. I want to install the modules from this source and then the actual version of apache via apt?

share|improve this question
    
"so that I can install php stuff" Please when asking a question be specific what you want. Do you want to install php or the php modules for Apache? –  Lucas Kauffman Apr 15 '12 at 11:58
    
ok i edited my questio. I want to install the module for apache –  soupdiver Apr 15 '12 at 12:00

1 Answer 1

I don't think there is any repo with apache 2.4 for Squeeze. I have tried to build it with modified dependencies.

Download debian sources:

apt-get source apache2 -t experimental

Modify dependencies in debian/control to older ones - available in Squeeze:

debhelper (>= 8.0.0~), dpkg-dev (>= 1.15.8.12~), libaprutil1-dev (>= 1.3.9))

And build it:

cd apache2-2.4.2/ && dpkg-buildpackage -b

Install with dpkg -i, it will need some more packages.

share|improve this answer
    
How did that workout for you? Was there any problems? –  Doug Jul 5 '12 at 8:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.