Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm in the process of setting up OpenVPN on a VPS running Debian 6. I've walked step-by-step through this guide twice now, and I can't get the service to start. When I start the service, the error reported in the log file is:

Cannot ioctl TUNSETIFF tun: Inappropriate ioctl for device (errno=25)

I've searched the web a few times and I'm not finding anything helpful. I've tried:

  • Changing file permissions: no change
  • Deleting the file: get an error stating no file found (errno=2)
  • Making a folder named "tun": get an error stating no file found (errno=2)

I've wiped my installation and completed the steps verbatim twice now. I get no errors along the way, just the error above within my log file. The contents of my server.conf file are listed below, minus all the comments for brevity. Can anyone help?

port 1194
proto udp
dev tun
ca ca.crt
cert myserver.crt
key myserver.key
dh dh1024.pem
ifconfig-pool-persist ipp.txt
keepalive 10 120
status openvpn-status.log
log         openvpn.log
verb 3
share|improve this question
It's possible your VPS provider isn't running a kernel with the "tun" module. Contact them to make sure about this. – cjc Apr 15 '12 at 23:27
up vote 1 down vote accepted

What type of VPS do you have? You may need your provider to enable TUN/TAP devices on the host node.

share|improve this answer
That solved it for me. Thanks for the tip! – Lenwood Apr 16 '12 at 6:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.