Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have tried to set up a VPN Connection on the Linux Mint disto, but could not get it working. When I use a Windows 7 VPN client it works fine. I brought up Wireshark on both Windows and Linux machine and noticed that on the Linux machine, the client never attempted to send the "Set-Link-Info" packet whereas the Windows (working) VPN client did.

Why isn't the Linux Mint client sending the "Set-Link-Info" packet. I think if it did that, then my connection would work. What am I missing?

Edit: Here is a copy of the /etc/ppp/options.pptp file. Thank you for the help:

###############################################################################
# $Id: options.pptp,v 1.3 2006/03/26 23:11:05 quozl Exp $
#
# Sample PPTP PPP options file /etc/ppp/options.pptp
# Options used by PPP when a connection is made by a PPTP client.
# This file can be referred to by an /etc/ppp/peers file for the tunnel.
# Changes are effective on the next connection.  See "man pppd".
#
# You are expected to change this file to suit your system.  As
# packaged, it requires PPP 2.4.2 or later from http://ppp.samba.org/
# and the kernel MPPE module available from the CVS repository also on
# http://ppp.samba.org/, which is packaged for DKMS as kernel_ppp_mppe.
###############################################################################

# Lock the port
lock

# Authentication
# We don't need the tunnel server to authenticate itself
noauth

# We won't do PAP, EAP, CHAP, or MSCHAP, but we will accept MSCHAP-V2
# (you may need to remove these refusals if the server is not using MPPE)
refuse-pap
refuse-eap
refuse-chap
refuse-mschap

# Compression
# Turn off compression protocols we know won't be used
nobsdcomp
nodeflate

# Encryption
# (There have been multiple versions of PPP with encryption support,
# choose with of the following sections you will use.  Note that MPPE
# requires the use of MSCHAP-V2 during authentication)

# http://ppp.samba.org/ the PPP project version of PPP by Paul Mackarras
# ppp-2.4.2 or later with MPPE only, kernel module ppp_mppe.o
# {{{
# Require MPPE 128-bit encryption
#require-mppe-128
# }}}

# http://polbox.com/h/hs001/ fork from PPP project by Jan Dubiec
# ppp-2.4.2 or later with MPPE and MPPC, kernel module ppp_mppe_mppc.o
# {{{
# Require MPPE 128-bit encryption
#mppe required,stateless
# }}}
share|improve this question
    
What does your /etc/ppp/options.pptp file look like? –  Wesley Apr 16 '12 at 6:49
    
Sorry for the delay, I could not check this until after work. Here is my listing of the /etc/ppp/options.pptp file: –  cabanaboy Apr 17 '12 at 0:28
    
Add the output of options.pptp to your original post. Something happened to your comment. –  Wesley Apr 17 '12 at 0:31
    
Yeah, it got cut off. I added the file to the post above. Sorry if that is not what I am supposed to do and thanks for the help. –  cabanaboy Apr 17 '12 at 0:32

1 Answer 1

In options.pptp, place the following lines anywhere:

mtu 1490
mru 1490
require-mschap
require-mschap-v2
require-mppe-128

Try the connection again. You may need to restart pppd


EDIT 1

There appears to be a mismatch in settings between the server and client. First, let's add the option to enable debug logging into options.pptp. Somewhere in that file, add the line: debug dump.

Next, before starting the connection again, tail the error log: sudo tail -f /var/log/syslog or /var/log/messages

Finally, start the connection again and see what the errors are in fuller detail.


EDIT 2

Looks like we've got an options dice game going on. Since the debug logging didn't shed any additional light on the problem, here's what should probably be done:

man pppd

Look at all the options available and start analyzing them. Change options using options.pptp and see if any change your situation. The error that's being reported strongly indicates that there is some kind of options mismatch between server and client, but it doesn't give any further information. Sadly, in cases like this, the next step is often to play option bingo.

share|improve this answer
    
I updated the file and I believe I restarted pppd, but no change. Here is the error I am seeing: Apr 16 19:06:54 <<localhost>> pppd[29760]: LCP: timeout sending Config-Requests –  cabanaboy Apr 17 '12 at 1:08
    
@cabanaboy Updated my answer. –  Wesley Apr 17 '12 at 1:36
    
Thank you for your help, btw. Here is the error message I get: Apr 16 19:42:15 [hostname] pppd[29882]: LCP: timeout sending Config-Requests –  cabanaboy Apr 17 '12 at 1:43
    
Got it. Thank you very much for your help. I will begin my game of bingo. If I figure anything out, I will post back to this thread. Thanks you again. –  cabanaboy Apr 17 '12 at 1:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.