Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

bind config

zone "minskmag.by" {
  type master;
  file "/etc/bind/named/minskmag.by";
};

zone file

$TTL    3600
@            IN      SOA     ns1.thestudio.by. root.thestudio.by. (2012041615 10800 3600 604800 86400)
             IN      NS      ns1.thestudio.by.
             IN      NS      ns2.thestudio.by.
             IN      A       178.159.244.101

command:

dig minskmag.by @ns1.thestudio.by

doesn't receive answer section

could anyone help me?

share|improve this question
    
Is this ns1.thestudio.by config and named config was reloaded after adding this? Does server has any views configured? –  Vadym S. Khondar Apr 16 '12 at 16:45
    
yes, it is configs from ns1.thestudio.by and bind server successfully reloaded server has no views –  yltsrc Apr 16 '12 at 17:54
    
Can you provide the dig output? Is the query getting an NXDOMAIN or SERVFAIL response, or simply timing out? What about if you dig @localhost from the server? –  Shane Madden Apr 16 '12 at 18:12
    
dig minskmag.by @178.159.244.101 ; <<>> DiG 9.7.3-P3 <<>> minskmag.by @178.159.244.101 ;; global options: +cmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 31776 ;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0 ;; WARNING: recursion requested but not available ;; QUESTION SECTION: ;minskmag.by. IN A ;; Query time: 472 msec ;; SERVER: 178.159.244.101#53(178.159.244.101) ;; WHEN: Mon Apr 16 21:15:54 2012 ;; MSG SIZE rcvd: 29 –  yltsrc Apr 16 '12 at 18:17
    
named-checkzone minskmag.by /etc/bind/named/minskmag.by zone minskmag.by/IN: loaded serial 2012041600 OK –  yltsrc Apr 16 '12 at 19:34

1 Answer 1

up vote 0 down vote accepted

Seems like your server simply does not know about zone you've configured.

  1. Check permissions to zone file.
  2. Check whether zone file lies where it should (you've used absolute file path - I'd avoid this as it complicates switching between chrooted and non-chrooted environment for named). Are you running named in chroot?
  3. Check logs for any additional messages about your zone (enable logging in named or enable logging for daemon facility in syslog).
share|improve this answer
    
thanks, i was file permissions –  yltsrc Apr 16 '12 at 19:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.