Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I see that there are two different releases in the Apache.org website.

one version is httpd_2.4.1 and another version is httpd_2.2.22 both are latest version.

any one have an idea? Thanks!! E.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Do you have a need to run a version other than what's available from the CentOS repositories?

It's pretty old, 2.2.3, but security fixes have been backported from the more recent versions.

Generally speaking, it's a lot easier to deal with maintaining package-installed software as opposed to self-compiled. Unless you have a very good reason to compile your own, use the package; and even if you do have a good reason to need the new version, there may be a third party repository out there with a package of the version you need (but be careful that you only use trustworthy sources).

If you do decide that you need the latest of one of the branches, you'll still need to choose between 2.2.x and 2.4.x; I think the only things you'll need to worry about there are module compatibility and configuration compatibility. If you need to use modules that don't yet work in 2.4, or you need to have the configuration on this system be compatible with other 2.2 installations, then stick with 2.2. Otherwise, use 2.4.

share|improve this answer
    
Thanks! I'm trying to run ab with option -r (Don't exit on socket receive errors.) but I don't see it on version 2.2.3-63.el5 but only on version 2.2.22. so I thought I'll install a 2.2.22 RPM instead and it works. what do you think? I still don't understand why Apache have version 2.2.X and 2.4.X. Thanks! E. –  edotan Apr 16 '12 at 18:28
    
A newer version of ab seems a silly reason to install a whole different version of Apache, but yeah, that should be fine. Apache still provides support for 2.2.x as well as 2.4.x because 2.4 is brand new; the vast majority of deployments still run 2.2. Some also still run 2.0, which had a bugfix release as recently as late 2010. There's even still some 1.3 out there. –  Shane Madden Apr 16 '12 at 18:51

Unless you have a compelling reason, you should use the one that comes with CentOS 5.x, which is 2.2.3-63.el5 (i.e., base 2.2.3, with current security patches backported from the latest release in the 2.2 line).

yum install httpd

share|improve this answer
    
Thanks! I'm trying to run ab with option -r (Don't exit on socket receive errors.) but I don't see it on version 2.2.3-63.el5 but only on version 2.2.22. so I thought I'll install a 2.2.22 RPM instead and it works. what do you think? –  edotan Apr 16 '12 at 18:26
    
If you're working from an RPM, that's fine: the problem with compiling your own installation is that the burden of maintaining the thing falls entirely on you. If you're working with packages, a lot of the hassle has shifted over to the package maintainers. –  cjc Apr 16 '12 at 18:32
    
I'm installing RPM from another repository centos.alt.ru/repository/centos/5/i386 –  edotan Apr 16 '12 at 18:35
    
Hmm. I've never heard of them. I probably would have gone look at rpmfind.net/linux/rpm2html/search.php?query=httpd and tried out the Fedora packages before trying a repo (in Russia) I've never heard of. –  cjc Apr 16 '12 at 18:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.