Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

CPU usage is ideal... as is everything else. It will start copying a file, say 700MB, then about 100MB in it will hang, and stop copying. It hangs for everyone else trying to access files on the server too.

After about a minute it will come back to live and start copying the file again.

Image of when it hangs: https://img.skitch.com/20120417-fwyju56xegtj78yc7je6nf7eqk.png

I have had a look at the HDD, and it seems to be quite fragmented. I was defragmenting it over the weekend, but it only got about 15% in, so had to cancel it. https://img.skitch.com/20120417-pbuuxgc5tmg7bxassprbuq29id.png

This partition is running on a RAID 1 HDD.

We (about 20) are all connected with gigabit ethernet. But at the time of this test I was the only one copying a large file.

It's been driving me nuts.

Any thoughts?

Edit 1:

About a month ago I swapped both HDDs with slightly bigger ones.

Both "Write caching" and "Advanced performance" are disabled with the 2 new HDDs. I think this may have been enabled before.

I recall reading somewhere that these settings could cause issues when enabled with our tape backups.

Does this really make a difference?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Take a good look at your drive(s). It almost sounds like maybe one of the drives in a RAID array has died and the controller is running in degraded mode. The fact the drive activity hangs for a bit and resumes sounds a bit like an old server that had a grumpy controller.

share|improve this answer
    
The server is about 4-5 years old. We are using Windows software RAID... As the hardware RAID controller was never setup due to some issues (this was before I was here). We are upgrading our server in a few months, but I have to keep this one running until then. –  Mint Apr 17 '12 at 8:25
    
About a month ago I replaced the current HDDs in the server with these 2 new ones as the old ones kept reporting bad blocks. We also needed more space. The issue seems to have arisen since then. But we have also been using the server more and more. So im not sure if it's the NEW HDDs or something else I done wrong. –  Mint Apr 17 '12 at 8:30
1  
I suspect that is probably your answer. There might be some issue with the older controller and the newer drives. You might try slowing the ports down if possible on the RAID controller. This might help even things out. Sometimes going slower helps smooth out the bumps. You didn't mention the server make and model (or the RAID controller). But I'd start there. Of course, just make sure you have a good backup before you go fiddling with the controller setup in case it barfs.. –  MikeAWood Apr 17 '12 at 18:44
    
Cheers, that fixed it. Along with defragging all the drives. –  Mint May 24 '12 at 2:16
    
WOOT, glad that fixed it... –  MikeAWood May 24 '12 at 21:37
add comment

First, update your NIC drivers to the latest version.

Second, open the properties of your network card within device manager and disable all features that use the word "offload."

Reboot as necessary.

share|improve this answer
    
Never thought about updating the NIC drivers. With give that a go tomorrow, let you know how it goes. Thanks –  Mint Apr 17 '12 at 6:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.