Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have a workstation (Windows Server 2008 R2 64 bit,IIS 7.5),and a web project deployed running in the same machine.Recently we received error that users cannot access web pages.Since then,we have learned IIS has stopped working and W3SVC service is not running. We also tried to re-run this service but it didn't work.For the last time,uninstalled and reinstalled IIS Web Admin then it worked for some time but again crashed.

I searched for similar errors like here,solutions here did not even work.

How can i fix this problem ?

Best Regards

share|improve this question
    
Can you check the application and system logs and post any pertinent findings? –  Chris Anton Apr 18 '12 at 0:28
    
I checked event logs regarding the problem,only errors I found are IIS-W3SVC-PerfCounters(EventID:2002) and IISInfoCtrs(EventID:1001).Could they possibly cause service to stop ? –  Myra Apr 18 '12 at 7:10
    
Not likely. Anything else in there? –  Chris Anton Apr 18 '12 at 12:46
    
Nothing like errors,I only found specific services in order to be worked for IIS are disabled,not working.Starting them individually,solved my case.However,they may again stop in the future,that's the reason i'm looking for. –  Myra Apr 18 '12 at 14:14
    
Are the service startup types set to Automatic? –  Chris Anton Apr 18 '12 at 16:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.