Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

im building a suse server. i have multiple copies of postgres running on it. i have the three instances running side by side just fine, the problem is when i try to get it to automatically start, i get this

 chkconfig -a postgresql5433
insserv: script postgresql5433: service postgresql already provided!
insserv: exiting now!
/sbin/insserv failed, exit code 1
postgresql5433            0:off  1:off  2:off  3:off  4:off  5:off  6:off

so my first instance of postgres is running and auto starting on boot but the other two instances are not.

how do i fix this?

thanks

share|improve this question

This is because of the INIT INFO block used to order services with chkconfig:

For example:

### BEGIN INIT INFO
# Provides: sshd
# Required-Start: $local_fs $network $syslog
# Required-Stop: $local_fs $syslog
# Should-Start: $syslog
# Should-Stop: $network $syslog
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Short-Description: Start up the OpenSSH server daemon
# Description:       SSH is a protocol for secure remote shell access.
#                    This service starts up the OpenSSH server daemon.
### END INIT INFO

You'll likely have to change the Provides: line to a new unique value.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.