Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed a backup software program (Retrospect 7.5) running on Windows Server 2008 R2 (a domain controller). When I open it says:

Retrospect could not be started under the specified user account (DOMAIN\Administrator) and is running under Local System instead. This can be corrected in Configure>Preferences>Security.

If I go there, everything is greyed out and unchangeable. Is it possible to login to the domain controller as "Local System"? If so, how?

share|improve this question

3 Answers 3

You can't login interactively as Local System on any system, not just a DC.

share|improve this answer
    
Any ideas on how to change the settings then? –  David Apr 17 '12 at 18:50
6  
Have you consulted the Retrospect documentation? It's usually a really bad idea to run any service under the Domain Admin account. –  MDMarra Apr 17 '12 at 18:50
    
Having a hard time finding any proper docs. The software is older, not sure if it actually supports 2008 R2... –  David Apr 17 '12 at 19:08
2  
Have you tried googling it? This seems to give plenty of results: google.com/?q=retrospect+7.5+documentation –  MDMarra Apr 17 '12 at 19:19

As far as I remember, you can use psexec to run a command under the local system account by passing it the -s switch.

Log into your DC as yourself, then use psexec to launch the software.

Check out http://ss64.com/nt/psexec.html for syntax.

Be careful though, although the local system account does not have privileges on the network, it will have full access to the local AD database... It's generally not a good idea to do this sort of thing if at all possible...

share|improve this answer
    
What does this do to solve the OP's problem? –  MDMarra Apr 17 '12 at 18:54
1  
I don't know if I'm misreading the OP's problem, but it looked like he was asking how to edit the settings of his backup software (I've never used it) under the local system account in order to sort out a problem. Launching the backup software using psexec -s will launch it under the local system account and he should then be able to access the currently greyed out settings. –  leftcase Apr 17 '12 at 19:01
1  
Sounds pretty risky! –  David Apr 17 '12 at 19:06
    
Ah, I see what you mean now. You're right, but I don't think that it will solve his issue. –  MDMarra Apr 17 '12 at 19:06
    
Hi David, to be fair, in terms of risk it's less risk than logging into your DC using the local system account (if that were possible) ;-) psexec limits the administrative access to the program you launch, and interactive login would run all programs with that level of access. –  leftcase Apr 17 '12 at 19:18

at the first time Download PsExec command from HERE this is PSTools ! then run this command : PsExec.exe -i -s -d "Your Program Location" this way make you to run your program with Local System Account Privilege

share|improve this answer
2  
Just like the answer that was posted almost exactly 12 months ago, then? –  Dan Apr 16 '13 at 9:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.