Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have setup squid proxy on an ubuntu server with DB authentication. However, whilst connected to the proxy, if I visit http://www.whatismyip.com/ it still shows my ACTUAL ip address. How can I configure Squid to hide my IP and to hide the fact it's using squid.

share|improve this question
    
Why do you want/need to hide it? – Zoredache Apr 17 '12 at 20:16
    
In order to be able to access IP restricted services without reealing the fact I'm using a proxy, like this: kickassproxy.com – gunwin Sep 11 '12 at 23:50
up vote 6 down vote accepted

By default, Squid has Forwarded-For turned on. For more info on what X-Forwarded-For is, have a gander at the Wikipedia article.

In your situation, you'll want to edit your Squid configuration file to include this line: forwarded_for off and then restart /etc/init.d/squid restart (assuming a RPM-based distro).

share|improve this answer
4  
In addition, you have to check 'Via' option (should be 'off'.) – Denis Apr 17 '12 at 20:47
    
@Denis, Excellent, thank you. – Wesley Apr 17 '12 at 20:54
    
This hides the IP address. Which is half the problem so thanks. But whatismyip.com is still able to detect that I'm using a proxy.. – gunwin Apr 18 '12 at 11:55
1  
The via option did it (in comination with forwarded_for)! – gunwin Apr 18 '12 at 12:25

I use this site to verify the proxy is properly hidden: http://www.lagado.com/proxy-test

It's not enough to set forwarded_for off! It will still send X-Forwarded-For: unknown, so others will know you use some kind of proxy (although your IP is hidden).

Add those 2 lines to your squid.conf file:

forwarded_for delete
via off

Then restart squid with service squid3 restart command, and you're done!

More information:

share|improve this answer

I am in Cuba and only after I did this in my squid:

forwarded_for delete
header_access From deny all
header_access Referer deny all
header_access Server deny all
header_access WWW-Authenticate deny all
header_access X-Forwarded-For deny all
header_access Via deny all
header_access Link deny all

...ALL pages so far, are allowing me to read content as I would be in France

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.