Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My ssl warning indicates:

The identity of this website has not been verified.
• Server's certificate is not trusted.

I'm using whm and i've generated the SSL and would like HTTPS to be enabled. I ran a ssl test and it indicated that port 443 is blocked: http://www.sslshopper.com/ssl-checker.html

No SSL certificates were found on xxx. Make sure that the name resolves to the correct server and that the SSL port (default is 443) is open on your server's firewall.

Now i'd like port 443 to be enabled. Would one enable this port through WHM or just through manually adding a virtual host for my hostnames?

Or is this warning generated because it's a self signed SSL certificate?

Managing SSL is a bit outside my sophistication level so please forgive me if i'm not making any sense. I'm willing to clarify to the best of my abilities.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

You need to enable 443 port from your server firewall. If you are using CSF (ConfigServer Firewall) then you will find ConFigServer Firewall feature in WHM. From there you can directly add port 443 in your Firewall. However, for any other firewall, you need to do it manually through SSH.

If you are using self signed SSL certificate then you may face this kind of error message. You can purchase private SSL certificate for your particular website from trusted SSL providers. For this you will have to assign dedicated IP address to your website and then generate CSR and purchase SSL based on that CSR key.

share|improve this answer
    
Thanks exactly what i need. –  chrisjlee Apr 19 '12 at 4:37

take a look at following:

Install a SSL Certificate and Setup the Domain

SSL FAQ

share|improve this answer
    
Read that link. Where does it talk about enabling port 443 ? Or do i not need to? –  chrisjlee Apr 17 '12 at 21:00
    
take a look at SSL FAQ –  alexus Apr 17 '12 at 21:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.