Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Ubuntu 11.10

Everything worked when I first setup statsd and graphite. Once I rebooted, it no longer works, which makes me think something about graphite or carbon needs to be started.

Now that I've rebooted, I go to a terminal and type

node stats.js dConfig.js

And statsd sayd "server is up". I have dumpMessages = true, so I see all of the messages hitting the statsd server.

Graphite is on the same machine so dConfig.js has dConfig.js also has port 2003 for graphite. I don't think I changed the port from 2003, but where do I find that?

The problem is, I cannot see any of the stats in the graphite console. I can nav to http:/ and see the graphite console. I even see old counters and timers. But I do not see any new data in the graph.

An example msg to statsd is:


So in graphite, I look for slolife / TimingTests, but cannot find that stat/folder.

What do I need to start or check to get the data to show in Graphite?

share|improve this question
up vote 2 down vote accepted

Turns out carbon was not running. When i would run this command:

sudo /opt/graphite/bin/ start

It would return:

Pidfile /opt/graphite/storage/ already exists, is carbon-cache already running?

I figured it was running. But I tried running, and it said it couldn't connect to port 2003.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.