Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to create a backup plan for my TFS 2010 server. This TFS server (MRSPOCK) is not part of a domain. My backup destination folder is a shared folder on a Windows 7 Professional PC (SCOTTY). However, during the readiness checks I get the following error:

[ Grant Backup Plan Permissions ] Account MRSPOCK\Administrator failed to create backups using path \\SCOTTY\Backups
[ Backup Tasks Verifications ] Account MRSPOCK\Administrator failed to create backups using path \\SCOTTY\Backups

The first results Google provided me was related to the backup folder having a space in its name, but mine hasn't. From what I gathered I assume the problem is due to the fact that my MSSQL service account does not have enough rights to write to that folder. When I tried to backup to a local folder this succeeded without issues. But of course, the point of backups is that they are not made to the same PC. :)

Unfortunately I don't know how I can do this as I cannot access the users of the other PC. Is there something I'm missing, or is there a workaround for my issue?

share|improve this question

I'm guessing you've long since solved your problem, but I just had this same error.

This article has a lot of good information

Turns out the service account using the share must OWN the share/folder. Having full control was not sufficient.

Changing the owner of the folder to the same account running the backups fixed my issue.

share|improve this answer

What are the permissions on the network share? Set it up for Everyone to have Full Control and try again. Make sure you're setting network share permissions and not NTFS file permissions.

share|improve this answer
As far as I can tell it's Full Control for everyone. And I enabled it using right-click, properties, sharing, enable share. Screenshot: From any PC, including the TFS server I can access the folder over the network and create and modify files and folders on it, just the TFS backup seems to be unable to do it. – Jensen Apr 19 '12 at 7:20
Maybe make an account on both computers with the same name and password. Use it in the tool as the task account for the backup tool and try again. – Tim Elhajj Apr 23 '12 at 5:02
I already tried that. I needed to do something similar for the automated builds so this was one of the first things I tried. I also posted this problem on the MSDN forums and it seems other people are affected by the same issue. Unfortunately nobody has been able to come up with a working solution. – Jensen Apr 23 '12 at 12:51
Did you try to map a drive from SCOTTY to MRSPOCK? Possibly try setting up homegroups on SCOTTY and adding MRSPOCK\administrator to the home group? This is a networking issue, not really an issue with the tool itself. It's complicated by the fact that I can't easily setup a similar environment here on the domain at work. :( Good luck! – Tim Elhajj Apr 23 '12 at 14:44
That didn't work either. I managed to do it by modifying the Log On user of the SQLSERVER and SQLSERVER AGENT service to my Administrator user. But I didn't really liked that. I've set it up to backup locally, and created a scheduled task using SyncToy 2.1 to echo the folder to my network storage. – Jensen Apr 24 '12 at 10:29

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.