Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I try to install mysql-dev package on Debian Lenny webserver. On my local home server, the same version it installs right but on the webserver I get a strange error.

I hope someone can help me with this one.

# sudo apt-get install libmysqlclient15-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libcups2 libsasl2-modules-sqlite3
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  zlib1g-dev
The following NEW packages will be installed:
  libmysqlclient15-dev zlib1g-dev
0 upgraded, 2 newly installed, 0 to remove and 9 not upgraded.
Need to get 7753kB of archives.
After this operation, 26.7MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
WARNING: The following packages cannot be authenticated!
  zlib1g-dev libmysqlclient15-dev
Install these packages without verification [y/N]? y
Err http://mirrors.nl.kernel.org lenny/main zlib1g-dev 1:1.2.3.3.dfsg-12
  404 Not Found
Err http://mirrors.nl.kernel.org lenny/main libmysqlclient15-dev 5.0.51a-24+lenny5
  404 Not Found
Err http://security.debian.org lenny/updates/main libmysqlclient15-dev 5.0.51a-24+lenny5
  404 Not Found [IP: 212.211.132.32 80]
Failed to fetch http://mirrors.nl.kernel.org/debian/pool/main/z/zlib/zlib1g-dev_1.2.3.3.dfsg-12_amd64.deb  404 Not Found
Failed to fetch http://security.debian.org/pool/updates/main/m/mysql-dfsg-5.0/libmysqlclient15-dev_5.0.51a-24+lenny5_amd64.deb  404 Not Found [IP: 212.211.132.32 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Thanks in advance.

Nick

share|improve this question

1 Answer 1

up vote 0 down vote accepted

It seems that Debian Lenny is not supported any more. As indicated here, it is supported until 2012-02-06.

share|improve this answer
    
Thank you very much, but it means I can't install this package now? I have to upgrade first to an other 'supported' version? –  user968898 Apr 18 '12 at 10:01
    
Yes, you can not install new packages. You have to upgrade to a supported version. –  Khaled Apr 18 '12 at 10:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.