Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is driving me crazy. I'm configuring the switch from the web interface.

Under: Switching > Ports > Port Configuration

I disable 'Auto Negotiation', I set the 'Admin Duplex' to 'FULL', I click on the 'Admin Port Speed' drop-down.. OOPS, only '10M' and '100M' are available.. does anyone knows where is the '1000M'?

If I set it to Auto Negotiation 'Enable', the port is well capable to work on 1000/Full, however I need to hard set the settings for a special device.

Has anyone seen this before? (Firmware 3.2.1.3)

share|improve this question
    
I tried the CLI too, and 1000 is not avail.. only 10/100... what is going on here –  ToastMan Apr 18 '12 at 15:03
    
jj33 answer below is correct –  SpacemanSpiff Apr 18 '12 at 15:11
add comment

1 Answer

up vote 4 down vote accepted

There is no "hard coded" option for gigabit ethernet. I believe that the protocol specification for 1000BASE-T dictates that it is available via auto-negotiation only.

From Wikipedia:

Autonegotiation is a requirement for using 1000BASE-T[8] according to Section 28D.5 Extensions required for Clause40 (1000BASE-T).

Which is itself referencing this IEEE PDF.

share|improve this answer
    
Hmm according to the Dell configuration manual here: support.dell.com/support/edocs/network/pc62xx/en/UG/HTML/… ... it says the following: Admin Port Speed — Forces the port speed to the selected value — 10M, 100M, 1000M or 10000M. –  ToastMan Apr 18 '12 at 19:16
    
Indeed it does say that, and the screen shot above it also shows "1000" selected in that drop down. And yet here we are =). I think you need to contact Dell support and find out what's going on. I can't say what's happening with your specific piece of dell hardware, but in general if you want to "force" 1000fdx, you leave auto negotiation on but don't allow it to negotiate anything but 1000fdx (see "Admin Advertisement" in the same docs you quoted) –  jj33 Apr 18 '12 at 19:31
    
when you disable "Auto Negotiation", the "Admin Advertisement" becomes greyed out :( I really appreciate your help! :) –  ToastMan Apr 18 '12 at 20:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.